maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E36 (1991 - 1999) (http://www.maxbimmer.com/forums/forumdisplay.php?f=59)
-   -   Have some issues with my e36 1996 318i !! (http://www.maxbimmer.com/forums/showthread.php?t=111404)

achnaide 10-05-2008 10:15 PM

Have some issues with my e36 1996 318i !!
 
hi,

Two major things I got:

1. My car shakes on idle. I checked with mechanic and saw it my self on the computer check that my rpm jumps in range 780-810 rpms. What could be the problem.?

2. I hear squeaking noise on the bumps and holes from the right side rear wheal. What is it shocks or something?

Thanks

adjei 10-07-2008 09:00 AM

srry this wont help but i have the same proble as you but mine jumps to 1300rpm

Trouble65 10-07-2008 09:23 AM

My son had a similar problem with his 329is I also had a problem with my 92 318is.

Have you checked your valve cover gasket.
They tend to leak with age, in doing so the spark plug and the wire short out causing the engine to shake.
Sometimes just by looking into the spark plug cavity you can see the oil leak. Other times the only way to resolve it is pull each spark plug out and make sure it's dry.

5style 10-07-2008 10:14 AM

ok, here is what YOU SHOULD DO.

1. idle high, inconsistent:

Check maf hose. the rubber boot between mass air sensor and the manifold. Guaranteed you have a hole in it. Replace boot, about 80 from bmw. I suggest you tape around the new boot with tuck tape, before you install, and tape tight and well. IT WILL CRACK AGAIN, usually within a year, its a POS rubber design. The tape will prevent this. If you can t see a crack, remove the boot fromt he car, you ll see one someplace.

Idle control valve: clean it, or replace it.

2. Squeeking= Handbrake: Replace pins. Usually squeeks on bumps etc.



Creaking: springs, if cracked they need replacing right away.

a properly running m42, or atleast one that gets proper air suction will start and idle at 800rpm and stay there consistently, on idle. I can almost guarantee its the MAF rubber boot, I just taped my old one, I don t want another one from bmw, im looking for a aftermarket one thats strong and durable.

achnaide 10-07-2008 10:34 AM

Quote:

Originally Posted by 405Style (Post 1210370)
ok, here is what YOU SHOULD DO.

1. idle high, inconsistent:

Check maf hose. the rubber boot between mass air sensor and the manifold. Guaranteed you have a hole in it. Replace boot, about 80 from bmw. I suggest you tape around the new boot with tuck tape, before you install, and tape tight and well. IT WILL CRACK AGAIN, usually within a year, its a POS rubber design. The tape will prevent this. If you can t see a crack, remove the boot fromt he car, you ll see one someplace.

Idle control valve: clean it, or replace it.

2. Squeeking= Handbrake: Replace pins. Usually squeeks on bumps etc.



Creaking: springs, if cracked they need replacing right away.

a properly running m42, or atleast one that gets proper air suction will start and idle at 800rpm and stay there consistently, on idle. I can almost guarantee its the MAF rubber boot, I just taped my old one, I don t want another one from bmw, im looking for a aftermarket one thats strong and durable.

Thanks, but how squeeking sound related to the handbrakes? Sound comes only from the rear suspension or specifically from right side rear wheal. It happens only on speed bumps or small wholes on the road. Also if i have passenger or two it squeeks all the time. :confused:

5style 10-07-2008 10:53 AM

Thats what mine was doing too. For me it was handbrake pins, they broke and my ebrake squeaked. However if i reversed first, then drove, it wouldn t squeek. Basically the ebrake shoe fell off on my car, and made squeeking noises on vibration.

Check your bushngs too, bounce the car while parked, ebrake off, out of gear, see if it creaks, creaks= suspension, most likely bushings or springs, no noise= ebrake squeeking.

achnaide 10-07-2008 11:06 AM

Quote:

Originally Posted by 405Style (Post 1210391)
Thats what mine was doing too. For me it was handbrake pins, they broke and my ebrake squeaked. However if i reversed first, then drove, it wouldn t squeek. Basically the ebrake shoe fell off on my car, and made squeeking noises on vibration.

Check your bushngs too, bounce the car while parked, ebrake off, out of gear, see if it creaks, creaks= suspension, most likely bushings or springs, no noise= ebrake squeeking.

my squeeks when car just stands and i push on the rear passenger side fender/trunk - it squeeks.

achnaide 10-07-2008 11:16 PM

ok guys. I fixed it. I had both springs broken. And the squeaking noise cased by one of the springs because it didnt had rubber part on one of the sides and was scratching directly on the metal. :(

but its over now *rockout*

5style 10-14-2008 04:18 PM

^^ sorry i was banned, yes, if it squeeked without being in motion, def, springs. did you get your vacuum leak fixed too?

achnaide 10-15-2008 12:39 AM

Quote:

Originally Posted by 405Style (Post 1213338)
^^ sorry i was banned, yes, if it squeeked without being in motion, def, springs. did you get your vacuum leak fixed too?

no i have not, still working on it

5style 10-15-2008 12:54 AM

You need a new MAF hose, and maybe a few of the other vacuum hoses, i am trying to fabricate a maf hose that is solid other then at the joints, to stop the cracking once and for all.

achnaide 03-21-2009 11:34 AM

!
 
sorry for the late reply... it was busy winter

....however i fixed idle problem , it was a hose :)

frankzen 03-27-2009 04:05 PM

Quote:

Originally Posted by achnaide (Post 1277339)
sorry for the late reply... it was busy winter

....however i fixed idle problem , it was a hose :)

Which one?

achnaide 03-27-2009 08:26 PM

!!!
 
1 Attachment(s)
check the hose indicated by the red arrow on the image below, because it usually melts of heat for some reason on many models.

Also check small gasket in the unit indicated by the blue arrow. As long as i remember this unit controls exhaust fumes which goes back to the engine -- i dont remember for sure i am not a mechanic.

I know that i fixed both of them. However my rpm jumps aint that bad.

P.S. i am planing to clean ICV valve and check more hoses, because issues above doesnt eliminate problem completely but my car works MUCH better.

frankzen 03-27-2009 11:30 PM

OK Thanks for the reply...

That's the PCV valve and hose--I'll check mine and maybe replace it anyway.


All times are GMT -4. The time now is 04:51 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.