maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   5 series (http://www.maxbimmer.com/forums/forumdisplay.php?f=61)
-   -   Display Pixels Disappearing ahhhhh!!!!!! (http://www.maxbimmer.com/forums/showthread.php?t=103230)

Dado 540 03-29-2008 01:53 PM

Display Pixels Disappearing ahhhhh!!!!!!
 
the display unit under the speedometer is a pixel display and some of them are missling and its driving me crazy. there are manuals on how to repair these missing display pixels. anyone have one or know how to do it on a E39 540i let me know?

Bullet Ride 03-30-2008 09:31 AM

i don't know if there are any manuals, its typically a dealer fix. if the car is under warranty, the warranty should cover it, but if not it's probably a pricey fix because i think they replace the whole gauge cluster here in Canada, i think state side in some places they just replace the screen and it costs like 100$, but for a whole cluster its something like 1000$?. You know how dealer likes to replace more parts than they need to make $$$.

Bottom line talk to the dealer, if its under warranty fix it.
i have dead pixels on my radio display on my 530, i'm not going to bother to fix it, shouldn't be listening to the radio in a BMW anyways.

good luck.

Qube 03-30-2008 01:27 PM

I have just one column missing on the Odo. Not to worry yet as my extended warranty covers it for two years... but I bookmarked:

http://forums.bimmerforums.com/forum...d.php?t=901626

and

http://bimmer.roadfly.com/bmw/forums...postid=1570167

Junaid 03-30-2008 07:20 PM

I'm not sure if it applies in Canada, but BMWNA pays for parts and you pay for labour to get the pixel issue fixeed

Gamite 03-30-2008 07:22 PM

BMWNA doesn't apply to canada. I have 2 lines out in my cluster too. I'm just gonna wait for more to go and then get a new cluster.

Junaid 03-30-2008 08:53 PM

That sucks...I thought Canada was included in North America. BMWNA should cover all of North America:rolleyes:

Qube 03-31-2008 12:36 AM

Quote:

Originally Posted by Gamite (Post 1131384)
BMWNA doesn't apply to canada. I have 2 lines out in my cluster too. I'm just gonna wait for more to go and then get a new cluster.

M5 cluster? That's gotta be some serious cash...

Gamite 03-31-2008 01:43 AM

Quote:

Originally Posted by Qube (Post 1131540)
M5 cluster? That's gotta be some serious cash...

yea like 1500 :(

Dado 540 03-31-2008 07:43 PM

thats too much....you can get some nice wheels for that money

e46it 03-31-2008 11:50 PM

this was just discussed not too long ago, See post #7 for the cheapest way to fix the issue, if you go with it let us know the outcome
http://www.maxbimmer.com/forums/showthread.php?t=102113

DINAN 3 04-01-2008 08:01 PM

Got lucky...
 
Had mine replaced under warranty and BMW gave me a modded one with stock M5 cluster rings (M-Tech style *love*) !

myndgone 04-08-2009 03:19 PM

Quote:

Originally Posted by DINAN 3 (Post 1132405)
Had mine replaced under warranty and BMW gave me a modded one with stock M5 cluster rings (M-Tech style *love*) !

Those rings look wicked...BUT...now you're not the only one with them, mine are in the mail, will have them installed shortly!! :P *par-t*

DINAN 3 04-08-2009 03:57 PM

^ Funny...
 
Got you hooked on 'em.

parm 04-08-2009 04:13 PM

I saw a e39 m5 cluster on kijiji.ca for $400.00 I am not sure if it's sold. Good deal if all is well with it.

MLue1 04-09-2009 10:46 AM

Quote:

Originally Posted by Dado 540 (Post 1130894)
the display unit under the speedometer is a pixel display and some of them are missling and its driving me crazy. there are manuals on how to repair these missing display pixels. anyone have one or know how to do it on a E39 540i let me know?

There are other ways to fix the pixel display but always try this one first:
http://bimmer.roadfly.com/bmw/forums/e38/1570167-1.html


All times are GMT -4. The time now is 12:10 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.