maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E46 (1998 - 2005) (http://www.maxbimmer.com/forums/forumdisplay.php?f=60)
-   -   Oil and Coolant lights (http://www.maxbimmer.com/forums/showthread.php?t=141193)

dunitlol 03-16-2011 09:55 PM

Oil and Coolant lights
 
When I start it up on some days the oil light and coolant light comes on, then about 2-5 min later it goes off. Other days its just one light but it goes off eventually... are my sensors gone?:confused:

**Edit** oil and coolant levels are fine.

B6T 03-16-2011 10:35 PM

Did you check your oil and coolant level under the hood? Are they within an acceptable level?

dunitlol 03-16-2011 11:47 PM

Quote:

Originally Posted by B6T (Post 1487410)
Did you check your oil and coolant level under the hood? Are they within an acceptable level?

lol yeah, sorry I forgot to add that in.

3SERB 03-17-2011 05:46 PM

Very likely its sensors,thats how my oil sensor behaved when it went.

uzi577 03-18-2011 03:07 PM

oil sender
 
I have have a very same problem
the oil light lights up every time I start the car.
The obdII says that the oil pressure censer is out.

dunitlol 03-20-2011 05:31 PM

Quote:

Originally Posted by uzi577 (Post 1487837)
I have have a very same problem
the oil light lights up every time I start the car.
The obdII says that the oil pressure censer is out.

Quote:

Originally Posted by 3SERB (Post 1487650)
Very likely its sensors,thats how my oil sensor behaved when it went.



alrighty, time to replace the sensors...thanks!


All times are GMT -4. The time now is 10:25 PM.

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2017