PDA

View Full Version : Failed emissions test 3X (w/ questions)


325isRED
08-08-2007, 04:50 PM
Failed all three sections of the rolling emissions test, I passed the curb idle though

__________Limit_____Reading
HC ppm_____60_______98______FAIL
CO%_______.33______.39______FAIL
NO ppm____450______684______FAIL


BUT there is something else, my tank currently has some Redline injector cleaner in it, I am sure that could have something that would hinder my results. AND they guy was doing 40K in second gear, and thus the RPM's where almost hitting 3k, I'm sure if it was an automatic car the car would be almost at idle, next test I'm going to ask them to stay in third.

What do you guys think? what do these three categories mean? and do you think the redline injector cleaner of the high rpm's had anything to do with it?

Thanks, Adam

M3ti Compact
08-08-2007, 05:08 PM
I don't know about the injector cleaner causing the bad results

however, I do know that the drive clean test is RPM based- not speed- so it won't matter what gear you are in- the tester still has to take it up to whatever RPM the computer tells him to test at.

325isRED
08-08-2007, 05:20 PM
I don't know about the injector cleaner causing the bad results

however, I do know that the drive clean test is RPM based- not speed- so it won't matter what gear you are in- the tester still has to take it up to whatever RPM the computer tells him to test at.

Are you sure? the guy at canadian tire told me the test is done at 40Km/h

Boots R
08-08-2007, 05:21 PM
Pfft. You should be so lucky.

When I did emissions earlier this year, my HC ppm was 940.

Are you sure? the guy at canadian tire told me the test is done at 40Km/h
They are based on 40km/h. It says so on your emissions slip.

325isRED
08-08-2007, 05:23 PM
Pfft. You should be so lucky.

When I did emissions earlier this year, my HC ppm was 940.


They are based on 40km/h. It says so on your emissions slip.

How did you get it to go down to required levels?

Gamite
08-08-2007, 05:25 PM
take it to a mechanic to see if there's something wrong with your car, which is what you should have done after you failed it the first time.

Boots R
08-08-2007, 05:26 PM
How did you get it to go down to required levels?
"Guaranteed to Pass". Did nothing.
Replaced cats. Did nothing.
Replaced o2 sensor. Did nothing.
Carbon Flush. Pass with flying colours.


Try some Seafoam.

Anything listed above could fix your car. Take it to a Mechanic to find out what's wrong.

StikiGreenZ
08-08-2007, 05:27 PM
Seafoam is great... Loved shooting white smoke at traffic for half an hour!

Eurostyle
08-08-2007, 05:31 PM
How did you get it to go down to required levels?

Cat if i remember well...

When they run the test, the computer shows the RPM and speed needed. If its outside the parameters, it will tell the technician to speed up/slow down to bring it to "specs"...so he cant fail you because of that...

Go to the "Automotive Test Center" on Shawson drive just west of Dixie, tell Tony i sent you, they do all the cars for BMW of Mississauga, and many other shops. They are good at diagnosting the problems...

325isRED
08-08-2007, 05:33 PM
take it to a mechanic to see if there's something wrong with your car, which is what you should have done after you failed it the first time.

I haven't taken the test tree times, I just failed in the three categories, my title is a bit misleading...

Seafoam is great... Loved shooting white smoke at traffic for half an hour!

do you just put it in the gas tank?

STALKER
08-08-2007, 05:36 PM
What is Seafoam?

spoony_prelude
08-08-2007, 05:44 PM
theres a link on seafoam on bimmerforums i think i remember seeing it, it doesnt go into your gas tank, theres a vacuum hose that goes to your intake manifold, thats where your supposed to put it to, ill see if i can find the link

spoony_prelude
08-08-2007, 05:46 PM
here it is

http://media.putfile.com/BMW-seaform

i should probably run some of this stuff on my car, i passed my emmisions with flying colours but who knows maybe itll help some more.

T.Dot_E30
08-08-2007, 05:47 PM
Are you sure? the guy at canadian tire told me the test is done at 40Km/h

Its a little bit of both, the technician has to maintain 40km, but has to keep it within a certain RPM range. (I believe it was above 1.5k but under 3.5k, but i haven't done an etest in so long i forgot)

Only if the car exceeds the rpm range while doing 40km, only then would the technician be allowed to switch gears. Other-wise the test is suppose to be done in 2nd gear.

Axxe
08-08-2007, 05:50 PM
Technician did my car in 3rd, but I told him to because the car has a 4.10 rear end.

e30bim
08-08-2007, 05:54 PM
I know a guy that will make you pass for the cost of the test +$100 Cash. It's from a place in the Oakville/Mississauga Area, he's a close buddy but I'm not going to mention any names because they can get their Drive Clean yanked if they get caught and a big fine.

e30bim
08-08-2007, 05:56 PM
But don't forget, you might actually want to get whatever is making you fail fixed b/c you could be getting shit mileage and/or burning out exhaust components or running a dirty injection/combustion system

T.Dot_E30
08-08-2007, 06:09 PM
Technician did my car in 3rd, but I told him to because the car has a 4.10 rear end.

He would have had to anyways, the rpm would have been too high in second.

Boots R
08-08-2007, 06:20 PM
I know a guy that will make you pass for the cost of the test +$100 Cash. It's from a place in the Oakville/Mississauga Area, he's a close buddy but I'm not going to mention any names because they can get their Drive Clean yanked if they get caught and a big fine.
Where the **** were you when I needed it. :(

325isRED
08-08-2007, 07:44 PM
anyone know what the deal is with a conditional pass? I hear its good for one year...

Boots R
08-08-2007, 09:21 PM
anyone know what the deal is with a conditional pass? I hear its good for one year...
If you spend up to a certain amount at the testing place you took it to (whatever is on your slip), and you STILL fail, they can give you a conditional pass.

It's a "pass" to the MTO, as long as you aren't transferring ownership. You need a 100% pass to transfer ownership.

///tyron
08-08-2007, 09:58 PM
Run 93 octane for the e-test. and jus before the test try get your engine hot.

325isRED
08-09-2007, 02:04 AM
Run 93 octane for the e-test. and jus before the test try get your engine hot.

I run sunoco 94 only (due to markD's chip)

Jim .E.
08-09-2007, 02:52 AM
seafoam it.

take a water bottle (the ones u can get from Longo's like the nestle purelife) . http://www.nestlewaterspa.com/images/bottle_sm.jpg

cut it where the second ribbed ring is (from bottom) which is roughly 1/3 of the bottle. pour seafoam in it, sip it through your pcv line (?)

you can also put some in your crankcase, but you will DEFINATELY have to do a oil change if you pour some in your crankcase

325isRED
08-30-2007, 07:59 PM
UPDATE:

Changed my oxygen sensor, and all of my numbers doubled!!! WTF!!!

Going to have to go the seafoam route...

Boots R
08-31-2007, 12:38 AM
lol you got a bad o2 sensor.

325isRED
08-31-2007, 01:39 PM
Did a seafoam treatment today, half in the intake manifold, half mixed with 30 liters of 94o gas...

I didnt see as much smoke as I thought I would, smoke was mostly blueish black. and It didnt smoke for long,

I'm leaving for the wasega tonight, and will do an oil change and a retest on tuesday!