PDA

View Full Version : Amp help, bridging


vegabass
08-04-2007, 07:30 PM
Hey guys,

i picked up this older amp, sapphire SA 1.5X without a manual or anything. I hooked it up and it works great, now the only thing is i dont know how to bridge the front and rear channels. It is a 5 channel amp, So i want to bridge the 4 channels to make it 2 channels and run the sub separate. It does not say on the amp and i cant find any info on it. If anyone knows or has experience with it, please help.

this is the site where u can get an idea of it:
http://www.phoenixgold.com/webfaq/Sapphire.htm

FuryriderX
08-05-2007, 02:46 AM
can you post a decent resolution photo of the speaker terminals? 90% of the time there is some indication of what terminal to use for bridging the amp.

typically though you'll connect the speaker to the L+ and R- or vice versa of the front channels, and same on the rear channels.

vegabass
08-06-2007, 02:03 AM
can you post a decent resolution photo of the speaker terminals? 90% of the time there is some indication of what terminal to use for bridging the amp.

typically though you'll connect the speaker to the L+ and R- or vice versa of the front channels, and same on the rear channels.

Here is a pic, but the amp does not indicate bridging connections.

Rally318ti
08-21-2007, 01:43 AM
Nice Amp bro! Old school Phoenix!! had the XS2500 before I sold the car that thing took a beating left right & center! SQ was pretty good in these amps as well ........email & Contact support@phoenixgold.com I'm sure they'll give ya an answer pretty fast!

vegabass
08-21-2007, 01:45 PM
thanks bro, do you think they will still carry the manual for it?