PDA

View Full Version : e46 with AA supercharger HELP


djeurofest1
07-21-2007, 08:57 PM
well over the past week or so, i got my supercharger installed. i bought a kit from AA (Active Auto) in flordia. i had my ECU shipped to them to get programed, well i got everything finally together but ran into troubles, maybe someone can help me out.


after the car sits overnight, i start it up, let the engine warm up a bit, and i drive... everything is perfect, once i let go of the gas/ slow down, the engine turns off, and everytime after i hit like over 3000 RPM or so the engine will turn off after i slow down (almost come to a stop) if i don't stop but slow down and try to drive the car just chokes

after like 5-10 min of driving, my engine starts to idel ****ty, but it sounds good lol, anyways, black smoke comes out of my exhaust like crazy when i'm at a light, when i give gas, it like chokes for a second then goes, but it doesn't seem that much faster! anyways after this my engine doesn't turn off anymore.

anyone have any ideas where to go or what i can do?

SickFinga
07-21-2007, 09:13 PM
vacuum leak somewhere

djeurofest1
07-21-2007, 09:34 PM
well i had a vacumm leak, but i found it, and still the same problem, it could be another vaccum leak?

Furious
07-22-2007, 03:37 AM
sounds like you still have vaccum leaks, have you talked to someone at AA about it? my kit was seemless when installed but i did have a vaccum leak later on and had similar issues, (found the leak and prob solved)

djeurofest1
07-22-2007, 06:40 AM
well, now when i take it for the spin, the car doesn't turn off, but its over fueled like crazy

i did 1/2 a tank in like 60 kms of driving,
and now chokes almost always

Furious
07-22-2007, 12:11 PM
hmm, maybe the tune is off than, sounds like its dumping obviously to much fuel, that could also be part of why the car wont shut off, that or your fuel pump is not shutting off.

also your sure your not leaking fuel? it could be the bad performance from fuel starvation and the reason why your getting 1/2 tank per 60k. i had a weird problem like that on another car where it only leaked when it was running, check it out as well its only a long shot

djeurofest1
07-22-2007, 12:30 PM
i am not leaking fuel anywhere at all, i checked plus out of my exhaust comes mad black smoke. (fuel)
also the bmws have that gauge that shows how much fuel its burning at the given time, my car is american, so it shows in MPG
and b4 the blower, when i floored it, the gauge would show approx 12 MPG when i was just driving normal, it showed approx 30 MPG
now when i hit the gas VERY lightly it shows max fuel 12 MPG

Furious
07-22-2007, 06:45 PM
call Jean at AA (if thats who you delt with)

SickFinga
07-23-2007, 11:22 AM
well, now when i take it for the spin, the car doesn't turn off, but its over fueled like crazy

i did 1/2 a tank in like 60 kms of driving,
and now chokes almost always


If your car doesn't turn off, it's probably your spark plugs. Put colder rating plugs in your car, and do not drive your car until you sort it out, it could end wih a blown engine.

Linz323
07-24-2007, 11:11 PM
Sounds like your bypass valve may be staying open, reducing the boost-- this can cause stalling. I had the kit for 2 years (selling it currently) and only had this once when the vacuum signal line came off.

As for the black smoke, the car is running super rich. Check the MAF sensor, as that could be it.

If you're car isn't showing "check engine" with those kind of problems, something is weird. Bring to a shop who can run the car and check for codes, adaptations etc. in detail to diagnose.

djeurofest1
07-24-2007, 11:27 PM
my check engine is on
with that black box HFM calibrator installed, if i unhooked the MAF or had it connected, no changes, which seemed weird.

so i disconnected the supercharger lines. so regular air runs to the intake, still smoked like crazy.
i took out the black box HFM calibrator and the black smoke went away, doesn't seem to be rich. put everything back together. and took the car for a spin!
the car doesn't choke anymore, nor does it run rich (no black smoke)
but after reaching a certain speed ( usually above 70 kms per hour)
the car changes gears really rough (automatic) and if i let go of the gas, the car will turn off, i either have to come to a complete stop to turn it on or put it in neurtal and start it then back to drive.

djeurofest1
07-24-2007, 11:30 PM
also AA is telling me i have a boost leak, which is the reason for this! but i checked everywhere, took it to my dads shop, and no leaks.
i think its something to do with that black box.

when that black box was connected, the car changed gears fine, didn't turn off but ran super rich....
seems like one problem is solved well another pops up, i think i will send that black box to AA from them to check it out, also send the ECU in for them to test with it, as i know for a fact everything else is fine!

djeurofest1
07-24-2007, 11:33 PM
somebody on a different forum told me to go this route, that do you guys think?
A few years ago I did an AA charger kit on a 330, great results but came across similar hurdles. For starters, you are runinng super rich, this is all the black smoke you are seeing out the tail pipe and the reason the car stalls at lights, there is just way too much fuel at idle and the car can't burn it...which leads to the stalling. as for the clearing up at wide open throttle, no surprise, I have seen forced induction BMWs power through 10:1 AFRs at wide open throttle and sputter and buck like mad at cruising speeds.

Solution, if you are running in tranny shifting problems(eek)..sounds like the ecu might need a reflashing/TLC. In the event you are running 8psi or less I would get a stock ecu and a product called the LMS Imanage, made by luxury motorsports in Cali. Will make your life very simple and make tuning a cinch. Another very important point, I hear no mention of a wide band 02 sensor and gauge in this car. For the money you spent on the kit go spend the extra few hundred and get the AEM wideband...crazy to tune any forced induction car without one...regardless of the manufacturer claims. Just my 2 cents..PM if you need more info.