PDA

View Full Version : HELP! - Fried my ecu?


vdubbedgti
06-09-2006, 07:24 AM
So I have been doing some welding on the floor of my e30, and some other minor work and now my car wont start. I have been doing some welding the past couple of weeks and I am pretty sure i forgot to disconnect the battery. Could I have fried my ecu? the problem is that about three days ago it started up no problem. after all the welding. the next day it was dead. battery was tested and recarged and still nothing. the motor would turn over but it just wont start. what could be the problem? ecu, fuel del, spark? Im still getting power to everything else, dash, locks etc. except my power windows. Help please. I just picked this up not to long ago, and I want to get it running so can drive it. I have also changed all the fuses, and i will be changing the plugs as soon as i get them in.

T.Dot_E30
06-09-2006, 11:25 AM
Do you have anything to check for fuel or injector pulse, if the ecu is fried the injectors wont be firing?

The ecu's are easy to change, its in the top lining of the glove box. Someone should have one for you.

Eurostyle
06-09-2006, 12:34 PM
i have a friend who is selling one...if you need it call me and i'll pass along the info...I think he is looking for $50-60 not sure...

vdubbedgti
06-09-2006, 05:12 PM
I've got nothing to check the injector pulse or fuel del. Im fairly new to the car mods, and DIY's, im guessing it s probably a good idea to either take it in to a shop and have them look it over, or swap out the ecu and cross my fingers. any other suggestions?

Chris de la Cruz
06-09-2006, 06:39 PM
i have one if you want... yours for $75

dirtyd14
06-09-2006, 08:28 PM
i got a "eta" 1987 325e ecu, (dont know which one u need) give it to ya for 50 bones!!

craz azn
06-10-2006, 09:19 PM
yo matt, I have an extra computer you can test out if you want... shoot me ur address and i can maybe drop by later on in the week. lemme know man

vdubbedgti
06-11-2006, 10:12 PM
Thanks for the offers on the ecu's dont know if thats it or not. so i want to try first.

Rudy - sent you my info talk to you soon. thanks.

Justin e36
06-11-2006, 11:23 PM
could be the ECU... or it could be.......

fuel tank is empty
battery terminals are corroded. (the engine will turn, just not quick enough to start.)
air filter is clogged
fuel pump is dead
fuel filter is clogged
ECU is dead / disconnected

... amongst other things. :)

vdubbedgti
06-12-2006, 03:31 PM
could be the ECU... or it could be.......

fuel tank is empty
battery terminals are corroded. (the engine will turn, just not quick enough to start.)
air filter is clogged
fuel pump is dead
fuel filter is clogged
ECU is dead / disconnected

... amongst other things. :)

fuel tank is good, air filter is new, ecu is the next thing to check, fuel pump and filter i should check out. and ther terminals are ok. thanks for the info *th-up*