PDA

View Full Version : Another Clutch Question....


Three_1_Eight
11-16-2005, 05:41 PM
Hey guys,

Can you please help me diagnose the problem (if there is any) that I am experiencing with my cluth pedal.

My car is a '94 318is and a new clutch kit was installed last spring.

This is very hard explain:
Now I don't remember if this has always been the case since I started driving the car, but now when I press down on the pedal (90% of the time, usually in first or when gearing down) I can feel the pedal making a clunck towards the end of pressing down on it. It does not do it on the way back up but only when I press down on it.

I hope I explained it right.

Any thoughts? Can I tighten the pedal up? Perhaps it is loose?

Thanks,
Tom

propr'one
11-17-2005, 09:23 AM
though i have quite a limited understanding of the clutch system on e36's, i think its far more likely that this is a problem with the pressure plate than the pedal itself. Unfortunatly, you may need to get at your clutch assembly and verify that the pressure plate isn't obstructed by anything in its motion towards/away from the clutch plate.

Three_1_Eight
11-17-2005, 12:49 PM
It happens when I want to get into first to start driving. It happens when the pedal is about 3/4 of the way down. I can feel like something is engaging.
Sometimes when shifting into second but after that nothing. It also does it sometimes when I am downshifting into 2nd. Then there are other times when the pedal goes down very smoothly.

Tom