PDA

View Full Version : central locking system problem


My318ti
10-30-2005, 10:19 AM
hey guys the central locking system on my car is not working properly. It hasnt been working since i removed the truck cylinder to try and get it repaired. I have since got the part back and installed it. Now whenever i open the driver side door with the key it only unlocks/locks that door (before it would unlock all the doors. And when i unlock the passenger side door it will lock/unlock that door and the trunk but it will continue to lock/unlock , lock/unlock up to 6 times each time i turn the key. And on top of this when i start the car the same thing happens with the passenger and trunk unlocking/locking a couple of times. Not sure if this is something i will need to replace or just need to reset the central locking module somehow.

Any help is appreciated

Justin e36
10-30-2005, 01:33 PM
First, check the usual stuff... fuses ok? central locking relay okay? .. if all is fine, then you will have to take out your drivers seat and pull up the carpet.

underneath here is where a bunch of wires ground to the chassis of the car... in time, this area gets rusted from moisture getting in the car and the ground gets killed. You'll have to fix this ground.

I know someone that spent over $1500 on their e36 trying to fix this problem from various shops and bmw dealerships. Took me two days of looking at wiring diagrams and testing/tracing every wire before I figured this out.

In your case, it seems like the trunk cylinder lock may be shorting somewhere or is not grounded. If you can get your hands on the wiring diagram for a Ti it would help a lot. You'll need to start testing wires and seeing which pulses are being sent and where the break is. I would check the grounds under the drivers seat first though.

My318ti
10-31-2005, 05:24 PM
perfect thanks for the help that is probably the problem becuase i removed the seats to clean the carpets and probably disconnected something and forgot to put it back