PDA

View Full Version : Help!!!!!!!!!


Waterwings
09-28-2005, 12:35 AM
I installed m50 intake manifold and i ****ed something up. The engine fires but won't stay on, and when it does for a second or 2 it knocks loud. I need help asap as i drive my car to work each day. PLease

JazzM
09-28-2005, 10:09 AM
Looks like your vacuum lines are not hooked up. Check your idle control valve... that dictates how your car idles and is most likely the cause of it stalling. Also make sure that your fuel pressure regulator line is also connected.

T.

Waterwings
09-28-2005, 10:36 AM
will do, i hooked em all up but maybe to the wrong ports or something i will check

RevShoT
09-28-2005, 10:39 AM
this will be a hard fix as if you put 1 vaccum line in the wrong spot it can cause a stall ect...

Waterwings
09-28-2005, 11:45 AM
well there are only 3 vacum lines going to the manifold correct, and 2 of the connect right to the piece that goes ontop of the eurosport adapter. and the third is that big mofo that is to the right of the manifold. correct?

JazzM
09-28-2005, 12:24 PM
this will be a hard fix as if you put 1 vaccum line in the wrong spot it can cause a stall ect...

You can put the vacuum lines to any location as long as they all go into the manifold.

Also, did you drill the manifold to plug the electrical connector or did you extend the electrical wires?

T.

Waterwings
09-28-2005, 02:10 PM
i plugged it with the screw that came in my eurosport kit

JazzM
09-28-2005, 02:11 PM
what about the valve cover vacuum line extention?

T.

Waterwings
09-28-2005, 02:20 PM
plugged that one with the other plug they sent

325iSBimmer
09-28-2005, 10:09 PM
check ur idle control motor.. I;ve had problems with them after a R&R. apparently they dont like to be moved around.. the symptoms were it would stall if u tried to let it idle on its own. but if u gave it gave and held it would stay on

Waterwings
09-29-2005, 12:08 AM
I put my old intake on so its a vaccum leak somewhere on the manifold i guess

Waterwings
10-02-2005, 03:05 PM
and the leak is........... at the intake ports. THe manifold is the wrong one. I will be knocking on someones door very soon for my money