PDA

View Full Version : Heater problem??


e36chick
09-27-2005, 09:39 AM
Well my heater doesnt seem to be working anymore...i turn it up pretty high and it's still freezing in the car. This morning i had it at 29 degrees but I might as well have turned it off and been driving with the window open, it was THAT cold.

now not to sound like an idiot who doesnt know how to use the heater....but am i doing it wrong?? i checked the owner's manual and this is supposedly the way to turn the heat up.

a/c works fine btw...cold air, but i am told the a/c compressor will need replacing soon. can this have anything to do with it?

thanks...

Justin e36
09-27-2005, 10:34 AM
... damn them digital climate controls.
it could be something wrong with your heating system.

mirek
09-27-2005, 11:15 AM
... damn them digital climate controls.
it could be something wrong with your heating system.

check to see if it works with the heat on your feet.

e36chick
09-27-2005, 11:51 AM
mirek i checked...its the same cold temperature at all the settings.

Waterwings
09-27-2005, 12:31 PM
did you spin the blue/red thing below the vent to the right of the dash to the red side?

Justin e36
09-27-2005, 12:48 PM
^^ .. she doesn't have a blue/red thing to spin.. she has a digital climate control... she has a late model e36 328is.

Waterwings
09-27-2005, 01:11 PM
yeah the same car i have, its the one below the middle air duct looks like the things that spin the vents open and shut, I also have digital climate control, but you have to move that thing to blue or red depending on hot or cold

Justin e36
09-27-2005, 01:21 PM
oh.. I know what you're talking about... the knurled wheel to change how much % of air is sent through the system again, and how much is just blown back out without being processed.

mirek
09-27-2005, 02:03 PM
if you're using the heat right and it doesn't work, my guess is your heater valve is gone... car doesn't overheat right?

e36chick
09-27-2005, 02:52 PM
no it doesnt overheat...the oil temp is in the middle where its supposed to be...

waterwings, i use the red arrow to move it up to hot...it goes by degrees and there is no difference between 16 and 29 degrees...the same cool/warm air depending on what time of day it is.

Waterwings
09-27-2005, 02:55 PM
no no, the vent above those controls, there are 2 pieces you can spin there. One to close the vent and one to the left with blue and red on it. Spin that one to the red side

mirek
09-27-2005, 03:41 PM
here is a pic

e36chick
09-28-2005, 12:12 AM
wow i dont remember seeing those controls in the centre...i have similae ones on the passenger side but there is no blue/red there. i'll check in the morning...

thanks a lot you guys!!!! :)

Waterwings
09-28-2005, 10:47 AM
yeah thats the pics i was looking for:D

Justin e36
09-28-2005, 10:59 AM
whoa, that cell phone is old skool.

mirek
09-28-2005, 11:13 AM
whoa, that cell phone is old skool.

yeah, that's the motorola razr v1 *th-up*

Gamite
09-28-2005, 06:42 PM
I dunno how E36 is, but is it possible that it could be her heater core valves? no coolant getting into the system? Do late E36's still use that system?

mirek
09-28-2005, 06:47 PM
I dunno how E36 is, but is it possible that it could be her heater core valves? no coolant getting into the system? Do late E36's still use that system?

i already said that *th-up*

e36chick
09-28-2005, 07:49 PM
is this coolant related?? bc my computer keeps flashing saying "check coolant"...i didnt pay it much attention bc my radiator blew not even 6 weeks ago, and i had it repaired at Dixie BMW...new radiator with 2 yr warranty. I figured they would have topped the coolant but maybe forgot to reset the computer??

mirek
09-28-2005, 08:07 PM
is this coolant related?? bc my computer keeps flashing saying "check coolant"...i didnt pay it much attention bc my radiator blew not even 6 weeks ago, and i had it repaired at Dixie BMW...new radiator with 2 yr warranty. I figured they would have topped the coolant but maybe forgot to reset the computer??

take it back to dixie bmw, this is related. system probably not properly bled

e36chick
09-28-2005, 08:16 PM
damn...ok. will call them tomorrow morning. thanks a lot mirek. :)

swiftkraft
09-29-2005, 01:13 AM
find out what it is, i am curious my system is doing the same thing, i think its the heator core or the valve, not sure yet.

e36chick
09-29-2005, 10:09 AM
ok now this morning i checked again with turning that top dial to the right (red section) and it WORKED...i have heat. i guess it didnt work yesterday cuz the car hadnt been driven overnight and the engine wasnt warm yet...

still gonna call Dixie BMW to find out why there is low coolant...for charging 750$ for a radiator/labour there is no reason not to fill the damn coolant back up.

mirek
09-29-2005, 10:44 AM
ok now this morning i checked again with turning that top dial to the right (red section) and it WORKED...i have heat. i guess it didnt work yesterday cuz the car hadnt been driven overnight and the engine wasnt warm yet...

still gonna call Dixie BMW to find out why there is low coolant...for charging 750$ for a radiator/labour there is no reason not to fill the damn coolant back up.

I did my rad, tstat, tstat housing for 390$ in parts.. i would have done all that for you for 600$ :D

Waterwings
09-29-2005, 11:03 AM
I knew it:D glad to hear you didn't have to spend cash to fix it

e36chick
09-29-2005, 12:30 PM
I did my rad, tstat, tstat housing for 390$ in parts.. i would have done all that for you for 600$ :D

i know...i heard from other people too how jacked up the price was. at the time i was stranded at dixie/401 and nothing but dealerships in sight...so i just took it there...tow there ( 4km!!) was 100$ too. :mad: