PDA

View Full Version : Need Help Please


Mobileman
07-09-2005, 10:36 PM
Hi there,

I have a 318ti, tonight she would not start. It would just go click click. Seems to be power in the battery as the lights and radio works.

What do you guys think...? Starter, coil ???

I have no idea

Any help would be greatly appreciated.

Justin e36
07-09-2005, 11:05 PM
first step, check your fuses... could be a fuse for something that blew, such as your ECU, fuel pump, starter, etc. which will cause the engine not to crank over.

next step, your battery posts could be corroded, enough power for radio and lights, but not enough to crank the engine. take the cables off your terminals, sand everything down, and reconnect tight.

if the problem still persists then we have to dig deeper, could be a bad started, corroded wires somewhere, etc.

Mobileman
07-09-2005, 11:12 PM
Thanks for getting back to me so quickly, I will check that first thing tomorrow. I'll let you know if it works.

Thanks again for the help.

propr'one
07-10-2005, 03:12 PM
318ti? thank god that happened to your lawnmower and not your car:D


last suggestion in addition to what justin said (which is more likely) is if the leads are not corroded, it may be your accual battery which has too little charge to start the car, but enough to power the radio. if you're sure the leads are good, you may try to boost the car.

Mobileman
07-11-2005, 10:00 PM
Well it turned out to be a dead battery, add the load test done and sure enough it was toast.

Thanks again for the help

Justin e36
07-11-2005, 10:35 PM
No prob.. :)

328is_Perf
07-16-2005, 02:14 PM
when it clicks, the gear head of the starter moves forward ... most likely its not getting enough power, i left my car's sound system on once for 2 hours on battery, and it would only click instead of start, so i pulled out the charger and started it..