PDA

View Full Version : Fixing DDE to lens


Antz_Marchin
05-13-2005, 04:19 AM
Just wondering what you guys have used to fix a DDE rind to a projector lens (epoxy? silicone?) and where you got it? I have to replace one on my ZKWs that I bought used (the guy told me one was out, sent a replacement and I got a good deal) and am not quite sure what to use. Anybody on here dont the DDE install successfully? Just seems like a touchy job and I'm nervous when it comes to working with expensive car stuff. Ah well hopefully it goes well. Any advice/help would be appreciated.

sloveniaboy
05-13-2005, 04:28 AM
I used small dabs of silicone to hold the rings on the inner part of the lense, no problems so far....

Antz_Marchin
05-13-2005, 04:34 AM
ok, I'll try that, thanks. Was it a tough install?...time-wise what shoud I be looking at? Also, off-topic a bit, did you just have to get the US module to get rid of the DRLs like you have (no lights) in your sig? Thanks for the help.

sloveniaboy
05-13-2005, 05:25 AM
time wise it can be however long you make it, I did it slow so it took a bit of time, I made sure I cleaned everything with rubbing alcohol and lense cleaner to make sure I left no residue after it all was put back together...last thing I wanted was to see a fingerprint or a chunk of epoxy that I forgot to remove...

for me the install went like this

-remove clips holding glass lense to housing
-cut away epoxy holding the two individual lenses
-remove lenses
-adhere rings to lenses using small dabs of silicone
-use silicone to adhere lenses to lense housing due to removal of epoxy
-place the inverter into housing behind shield
-wire up inverters to rings
-wire up city lights to inverters
-slowly mate the lense to the housing while tucking the wires away neatly
-finally, place clips back into place and wire up the angel eyes to corner lights

For the DRLs, found out what was what in the fuse box and just wired up an on/off switch to the low beams, also wired one up for the angel eyes...

Antz_Marchin
05-13-2005, 03:10 PM
Cool, thanks for the DDE step-by-step. I'll be doing that one this weekend if I have time, oterwise this week. Also, for those fuse-box switches, I'd love to hear more. My dad is an electrician, and I'm hoping as he can give me a hand with this. Where did you end up mounting these switches? Thanks for all the help. Take it easy.

sloveniaboy
05-13-2005, 04:06 PM
here is the original thread from a year ago

http://www.maxbimmer.com/forums/showthread.php?t=36709&highlight=switches

Antz_Marchin
05-13-2005, 05:26 PM
Cool, thanks man.......damn that's a professional looking job. Do you have a $rate$ to do house calls : )

sloveniaboy
05-13-2005, 06:21 PM
Cool, thanks man.......damn that's a professional looking job. Do you have a $rate$ to do house calls : )

lol, when it comes down to it, it's pretty simple, good luck with the install man *th-up*

Antz_Marchin
05-15-2005, 07:18 PM
One more quick question. I had everything all ready to go and when I wen tto put the lens back into the housing with the new DDE and the Silicon applied ot the edge, I was working ti in VERY carefully when the one little black clip snapped. So, am I screwed or can I work something out to keep the lens in place......damnit I hate these things.

sloveniaboy
05-16-2005, 12:40 AM
ya, this has happened to many others.....just run a nice bead of silicone arround the lense and the lense housing, this should hold it

good idea to heat up any plastic clip that would be stressed, such as the clips on the side of the light housing when doing the final assembly of lense housing and light housing