PDA

View Full Version : 2 new goodies arrived.


AlpWhitE46
04-30-2005, 01:44 AM
finally after a month of waiting for a shipment in toronto, guess it got lost, so they sent it out yesterday and got here today...

silver gauge rings, and new LED lights.

E36er
04-30-2005, 02:30 AM
nice rims and lights....so where are you putting the lights? rear? or corners?

AlpWhitE46
04-30-2005, 02:54 AM
nice rims and lights....so where are you putting the lights? rear? or corners?

huh?

i got silver gauges and LED interior.

Understated
04-30-2005, 07:38 AM
i think he thinks the pchop is real :D

anywho ur car is gonna be pretty good lookin mang....silver rings are always amust on an e46 cluster *th-up*

post pix after the install *smoke*

Rampage
04-30-2005, 09:34 AM
Cool!

Awaiting pics of install *th-up*

myndgone
04-30-2005, 10:48 AM
i ordered the same, and it got lost in the mail...wtf's wrong with those ppl at bimmian?! :D

they're shipping another order monday..cant wait....i got chrome rings for my 540.

post pics when you're done, I'm dying to see what those LEDs look like....


BTW, how much was your duties & brokerage fees (if any)?!

Soldo
04-30-2005, 01:47 PM
Are the LED's real HID led's or are they that fake blue zenon crap?
And how much did they run you?

AlpWhitE46
04-30-2005, 02:58 PM
Total was $165 CDN after everything (tax n shipping)
pretty expensive, but whatever..i doubt i will be shopping with Bimmian again, too many stories from other people, and it happened to me.

Soldo, they should be real... they are xenon colored illumination...
but they dont appear blue while they off unlike the other xenon bulbs

SpoolinS6
04-30-2005, 03:32 PM
wasnt this car for sale or it had to go ? and ur still doing shit to it ?

E36er
04-30-2005, 03:33 PM
huh?

i got silver gauges and LED interior.


lol my bad, its just ive seen those lights at Canadian Tire and they can fit in your corners or rears, but i guess there different lights!.

edit: i guess if i read the box and looked close enough i would have saved myself from looking stupid!

BMW_7
04-30-2005, 04:04 PM
I want Bimmian's blue interior bulbs, they are cheaper....
But now I don't think I will be dealing with them

What payment method did you use? Credit card?

BMW_M52_M20
04-30-2005, 04:07 PM
Where did you get the silver gauge rings from?
$?

Thanks

AlpWhitE46
04-30-2005, 05:37 PM
bmw m52: 35 bux i think, bimmian...


This ****ing sucks, the day turned out so shit, took the whole cluster off, and then i realized i didnt have any glue, and the other car isnt at home...

so then thinking the bulbs wud be a 15 minute easy isntall, guess what? Took about 1.5 hours....and the only LED bulbs in there are the main front 2 BULBS.....
I am so complaining about this ****ing shit..

what happened was i put in the front (reading lights) and they worked fine...put in the rear left one, worked fine...put in the rear right one...
whoops, nothing worked anymore at all...
so went in the glove box department fiddeled around with the switches, and NOTHING worked...so i tried other LEDs and still nothing...
put back in one regular one in the rear left, viola, whole thing works....
so i switched out the back with the regulars...and it works ok... (impossible to get them all to work)
So i move on to the trunk, switch the LED's in, guess what , they are on ALL THE TIME...impossible to ever turn them off (they just glow brighter when the lights are turned on)...

SpoolinS6
04-30-2005, 05:39 PM
so the car isnt for sale anymore ? LOL !

AlpWhitE46
04-30-2005, 05:41 PM
so the car isnt for sale anymore ? LOL !

next spring.

AlpWhitE46
04-30-2005, 07:53 PM
rings are on, looks like i will not be using the LED's

http://www.e46toronto.ca/forums/attachment.php?attachmentid=1708&stc=1

http://www.e46toronto.ca/forums/attachment.php?attachmentid=1709&stc=1

http://www.e46toronto.ca/forums/attachment.php?attachmentid=1710&stc=1

BMW_7
04-30-2005, 08:26 PM
Dude that sucks, I would return them if I were you...I think $167 for ****ing bulbs - NOT even LED's is a joke....Canadian tire probably has some.

AlpWhitE46
04-30-2005, 09:25 PM
Dude that sucks, I would return them if I were you...I think $167 for ****ing bulbs - NOT even LED's is a joke....Canadian tire probably has some.


actually 167 was all together with the rings + shipping + tax...
but yeah its still pricey, the LED's are i think 80 or so..but lifetime warranty.

and to clear it up this is actually what hppnd.
The center console lights worked fine... (2 of them turn on when the button is pressed)

The rear left one was put in...closed (light turned on and all worked fine)
The rear right one was put in..... closed (pushed button, nothing worked nemore)
It does not matter wheteher its the left or right one...but when all 4 are in, they cant work...
i tried different LED bulbs, still nothing....
then i switched one of the rear's back with the factory BMW light...and all 4 turned on fine (so 2 front LED's one rear LED and one BMW light)

AlpWhitE46
05-02-2005, 12:03 AM
found out the problem... (its not cuz of me though..)

still dont have it resolved though...here is a pic at night of gauge rings + Front LED's

http://www.e46toronto.ca/forums/attachment.php?attachmentid=1718&stc=1

http://www.e46toronto.ca/forums/attachment.php?attachmentid=1719&stc=1

http://www.e46toronto.ca/forums/attachment.php?attachmentid=1720&stc=1

sonny
05-02-2005, 12:56 AM
Where did you buy the gauge rings from? How much did they cost?

AlpWhitE46
05-02-2005, 01:16 AM
Where did you buy the gauge rings from? How much did they cost?

www.************

40$

ClayMan
05-02-2005, 01:19 AM
Polarity matters for those LEDs... You sure you didn't put them in backwards?

sonny
05-02-2005, 01:16 PM
The silver rings do not have the adhesive on the back, only the chrome rings do. So how did you mount them?

AlpWhitE46
05-02-2005, 04:40 PM
clayman: yes i know that, here was the reply....

"Sorry to hear about this problem,
1. regarding the license plate lights, these lights take SO little power that the capacitors that charge in the circuit cause them to stay lit for a couple minutes afterwards. Be patient they will go out.

2. regarding the lights not working when you replace all bulbs, this is a problem we are trying to work out. It happens on about 2-5% of vehicles, no way to tell which ones.

We can do one of two things: send you a replacement interior xenon set plus give you a $30 site credit (double the cost diff between the two sets)

Give you a couple regular Filament interior xenon bulbs, run these in the rear of the car reading lights, when we figure out a solution it will be provided to you"

sonny: glue.