PDA

View Full Version : is my t-stat dying?


myndgone
04-27-2005, 08:17 AM
This morning the temp went up to 3/4 mark, its been in the dead center ever since i got the car...went to the 3/4 mark, then all of a sudden went 'almost' back int he middle, then you could kind of see it 'jump' a little back to the 3/4 mark, and then it slowly went back towards the middle mark...

I searched for previous posts, but nothing exactly like this...or am i blind?! :D


t-stat on its last breath? fan clutch?
rad was changed 2 months ago!

Gamite
04-27-2005, 12:02 PM
well, check the fan clutch first, since you don't need to open anything up for that. If not, its probably the stat.

RevShoT
04-27-2005, 12:45 PM
i think u bought a lemon holy geeze!!! ur always breakin down!

myndgone
04-27-2005, 01:03 PM
i think u bought a lemon holy geeze!!! ur always breakin down!

looks like it! *sad*

OILERS
04-28-2005, 12:38 PM
i've been having similar problems. when the stat is going up to the 3/4 mark. are you in slow stop and go traffic. when it goes back to the middle, did you just pick up some speed and got out of traffic. if that's the case, like mine, it was my fan clutch.

myndgone
04-29-2005, 11:07 AM
it turned out to be the t-stat after all...

i called Charlie up and he said it was the t-stat right away, went to pick it up, car almsot overheated on the way there, it was cool that he wasn't too busy to change it for me, very cool dude, you can tell he knows his sh!t, and i can honestly say that noone but Charlie is allowed to work on my car....ever!!!

Thanks dude, I appreciate it! *th-up* *th-up* *th-up* *th-up* *th-up*
See ya in 2 weeks (need a few things done)!!