PDA

View Full Version : **Suspention problem


ierrahh
04-24-2005, 08:35 PM
This morning I had a flat fixed at goodyear and obviously the car was put on a lift. When I drove away I noticed a panging noise everytime I hit a bump with the right rear tire. The flat that was fixed was on the left so they didn't touch the right side but I did have my suspention done a week ago somewhere else (Bilstien shocks & H&R Race Springs). At first I thought that my back seat wasn't snapped in properly but it was and I had my girlfriend go in the back while I was driving to see if she could tell where it was coming from. It's coming from inside the hub above where the screw is for the shocks inside the trunk....Anybody know what could be wrong???

BTW the ride still feels the same as before the problem but the noise is getting worse I think

Jari
04-25-2005, 01:50 AM
It might be your shock mount. When you had the suspension done, did you change the mounts as well ? I blew a mount when I had my suspension changed. Basically it's the rubber from the mount that seperates, and now your shock is traveling up inside the trunk and the banging you're hearing might be the shock mount slapping against itself. It's pretty easy to diagnose. Just remove the trunk liner and have someone bounce the suspension while you check to see if that mount is solid, or does it pop up everytime the car is pressed down.

ierrahh
04-25-2005, 08:15 AM
I didn't have it replaced and I tried what you had said and it does pop up, I'm going to have them both replaced today...Thanks