PDA

View Full Version : Xenon Problems


bimmerchop
03-15-2005, 12:42 AM
Ok, so today I was all excited about finally taking my car out of winter storage, but then my mood switched over from excited to upset because my god damn xenon light bulb on the drivers side went out. Question is, is it the xenon light itself that is f ucked up, or is it a connection problem. Reason why I'm asking is because when I start the car, I have no warning lights on my dash, but as soon as I go to turn the switch for the xenons, what happens is the one on the driver's side flickers on and off really quick for about a second, then stays off, and then the warning light on the dash comes on. The passanger side one is fine. If the bulb really was out, would it still flicker like that? Let me know what you guys think, I don't want to go spend $ on a new xenon light set if it's only a connection problem. Maybe the ballast?

:(

Daydream///M3
03-15-2005, 02:28 AM
first things first, swap bulbs from passenger side to driver side and see what happens... a very easy thing to do and will take minutes but will tell you a lot. I used to haev a flickering bulb but when I switched sides, it went away and both bulbs worked.

ara325
03-15-2005, 09:04 PM
i know this sounds stupid, but try tapping the lense, sometimes my foglight gets testy and won't turn on, but after tapping the lense it works fine.

bimmerchop
03-16-2005, 01:20 PM
Thanks for the suggestion guys. I was hoping someone had experienced something like this before I swapped bulbs to test though. It's such a bitch because I'm going to have to remove my ECIS b/c of the heat shield.

ara325
03-16-2005, 01:24 PM
How about getting it checked at the dealership?

bimmerchop
03-16-2005, 01:29 PM
I was going to, but decided not to. No way in hell will I ever bring my car back to the dealership for service. Not only am I out of warranty, so they'll charge me an arm and a leg, but they also take really bad care of your car when it's in for service. Last time they completely scratched my front bumper, and it took a bit of arguing to get to atleast touch it up. I brought my car to a shop(BMW only garage) yesterday, and the tech there told me right away it was the bulb w/o making sure. he said he's seen that problem before, and he's pretty sure it's the bulb. I'm still a little worried it's the ballast, so I'm going to try and switch the bulbs later on when I have a bit of free time.

3CAB
03-16-2005, 09:29 PM
I have the same problem. I turn on the headlight and it starts to flicker for a bit and them turns off...Please let me know the solution to this problem when u do...thanks

ara325
03-17-2005, 03:43 PM
I was going to, but decided not to. No way in hell will I ever bring my car back to the dealership for service. Not only am I out of warranty, so they'll charge me an arm and a leg, but they also take really bad care of your car when it's in for service. Last time they completely scratched my front bumper, and it took a bit of arguing to get to atleast touch it up.

It's funny you say that b/c a couple of years ago I had my car at the old Town & Country BMW (just north of Steeles) for a fan belt change etc...it was the closest shop when my belt snapped. When I got it back, there was a huge gash on the front bumper under the kidney grills. I spoke to 2 managers and the mechanic, and then the General Manager. He agreed that they couldn't prove that it was there before I brought my car in (which it wasn't) so they agreed to repaint the front bumper. On top of that, they gave me an e46 323i (this was in 2000) as a loaner for a week. So, in the end, they took care of me, it's just surprising that something like that would happen at a BMW dealership...their mechanics are "factory trained" and the shop bays are design such that there is minimal chance of damage to the car...well obviously I proved that wrong... *th-up*

Daydream///M3
03-17-2005, 07:56 PM
come to think about it, it may be the relay

bimmerchop
03-18-2005, 05:41 PM
Ok guys. I finally got some free time this afternoon to swap bulbs. A simple bulb swap took me about an hour :mad: Simply because 1, I had to remove my ecis intake because the heat shield was in the way, and 2, the clip you have to twist that holds the socket for the xenon bulb was stuck, and I couldn't twist it to pull it out. Anyways... I finally got the "bad" bulb out to test it. I just plugged it into the passanger side socket/ignitor. Went, turned them on, and it did the same shit on that side(flickering, then not turning on). So I figure it's got to be the bulb, right? Not the ballast or relay, or connection. Now I think it's time I upgrade to 6000K xenons. Problem is, after doing some searching, and looking at pics, some show them having a tint of blue, others showing them being pruple. Now i don't want pruple lights on my car and have never seen these in person. Anyone wanna give me some feedback on them? The 8000K might be a little too blue for my taste and also they supposedly really decrease visibility at night when compared to stock, so I've heard.....

T.Dot_E30
03-18-2005, 09:36 PM
6000k

bimmerchop
03-18-2005, 10:17 PM
^^ See, that looks perfect to me. But then i see other pictures and they seem purple wtf is up with that? I wish there was like a 30 day free trial type of thing with the LOL

Daydream///M3
03-19-2005, 02:50 AM
one thing to keep in mind is that most people will post pics of their xenons when they fire them up..... which makes them more blue than any normal running bulb.
Also, pictures tend to make the colour more blue than it really is on most occasions.

If you want an idea of what colour the bulbs look like, try to locate someone witht he bulbs you want and go see them in person.
You might wanna look at Bruces.... they look good in person

mmpower
03-19-2005, 03:16 AM
I bought some 6000k for my E46 and installed them last night. I will take pics tomorrow evening and post them up!

Btw, I bought mine from www.bimmian.info!

Gamite
03-19-2005, 03:36 AM
^^ See, that looks perfect to me. But then i see other pictures and they seem purple wtf is up with that? I wish there was like a 30 day free trial type of thing with the LOL

I have 6000K and yes, they look purple. I kinda like it though.

bimmerchop
03-19-2005, 02:02 PM
Yea I know what you guys mean. When searching around for pics, some show them really blue, while others show them purple. I'm looking for a set that has a slight tint of blue to them. Like a whitish blue. 8000K I think might be too blue for me. I can't seen to find someone around in my area either that has 6000K xenons :(

R_JAY
03-19-2005, 02:11 PM
Here you go Rich. 6000K after the car was running for about an hour and a half.

Pawel_11_11
03-19-2005, 03:43 PM
it all depends on what company makes them, I've seen phillips 6000K and their nice and blue, while the 8000K was quite purple, also I've seen hella 12000K and they looked similar to the 8000K, so it all depends on the rating system. Go to http://www.xenondepot.com/ their located in thornhill, and they have pretty good prices, and I know you get what you pay for, but one of my buds put em in his acura a year ago or so, and they still work well, they also have pics of different shades. I got projection lights and it sucks cause the colour of the HID gets so distorted by the projector that I decided to go back to the regualar H7. Let us know what heat colour you go with and how they look!

3CAB
03-22-2005, 07:49 PM
where can u buy these bulbs?(6000 and 8000)...
Are u guys gettign it from he dealer or somewhere else?
PLease let me know...i have the same problem wiht my lights

Slowered318
03-22-2005, 08:37 PM
Gamite... that's strange how yours look purplish.. i have the exact same headlights and 6k HID kit.. but mine are pure bluish white.


on the left.