PDA

View Full Version : Shot ECU


Goran
06-21-2004, 11:00 PM
I think my ECU broke today.....in the morning the control lights were flashing when the car was turned on (e-brake, oil light, brake light, etc.). Later at night my Cd player started going crazy, lights flashing not playing music........ I shut off the car and when i went to turn it on i had trouble it wouldnt start, anyways i got it started drove home and now it wont fire at all.......batterys good all power options work but the CD player only works when the key is turned to position one........If anybody can confirm this is an ECU problem or if anyone has any IDEAS please msg me or post......... i need this fixed asap!!!!!!!!!!!!!!

If anyone has a spare ECU Ill buy it off them

jeffrie
06-21-2004, 11:47 PM
sounds pretty screwrey but am positive ecu has nothing to do with radio, would replace ignition plug (other side of were key goes) not the metal casing just the plug on other end.
Too similar to what happened to my audi to be anything ealse.
my 2 cents
Jeffrey

BMWE30
06-22-2004, 12:38 AM
Doesnt sound like an ECU problem...sounds more like the charging system/alternator or a bad ground. It could also be a loose/corroded or disconnected wire. Have the charging/electrical system checked and possibly ignition system also.

chromius
06-22-2004, 11:49 PM
^^^^I second that. Possibly a shot voltage regulator off your alternator, thats why it works when at position one, cuz its running off battery....check for any signs that the battery has been boiling, such as acid in the battery tray, thats a tell tale sign that the regulator is shot.