PDA

View Full Version : E30 woes........Solution hopefully!


BMW_M52_M20
05-11-2004, 07:03 PM
Okay Guys,

I have had an on going problem with eratic idle (hunting) and my car cuts out on and off during acceleration and has poor cold starts. I have exhausted every option before diving into the fuel injectors:
Here are the items I have replaced for similar problems:

Fuel pump
Fuel lines
Fuel tank
Fuel filter
ICV valve and module
vaccum hoses
spark plugs
cap and rotor
ignition wires
Cold start valve

Anyways, enough was enough and I took it over to my Mechanic at Cross Avenue and he is replacing all 6 fuel injectors (OEM BMW)
and installing a new fuel pressure regulator. Each fuel injector is $177.00!!!!
I am going to hold on to this car for a bit and I have sunk a lot of money into this car so I am praying this will solve my problems. I can't see what else there could be left to do.
I will let you guys know tonight on how things went.
Jay

Slowered318
05-11-2004, 07:22 PM
what about the coolant temp sensor.. i'm replacing that in my bro's 325 i'll let you know if it fixes the problem of rough idle and bad cold starts

BMW_M52_M20
05-11-2004, 07:40 PM
Sorry, forgot to add that to my list, has already been done!

Slowered318
05-11-2004, 08:15 PM
Originally posted by BMW_M52_M20
Sorry, forgot to add that to my list, has already been done!

and that didn't fix it obviously.. damn :mad:

felixthecat
05-11-2004, 08:33 PM
damn bud....i would nave given you 6 injectors...i have a bunch from my other motor i'll never use...

BMW_M52_M20
05-11-2004, 08:38 PM
Originally posted by Slowered318
and that didn't fix it obviously.. damn :mad:

Nope. It has been an on going battle, but I figure, hey I put the money into it, I will have nice original bimmer that I can just mess around with in the summer. I have to get another car by the end of the summer anyway.
Jay

Jase
05-12-2004, 12:00 AM
Is the car pushing any smoke?
Jase

BMW_M52_M20
05-12-2004, 12:44 AM
nope, very clean running actually.

bmdoubleya
05-12-2004, 02:17 AM
Have you replaced your AFM??? My buddy's 4 door had the same problems ... We replaced the AFM and fixed the problem for the season but then it came back the next years... That time it was the rubber intake boot had cracks in it which was letting in un-metered air..

Check your intake boot for cracks and tape it up or replace it.

Sim_Sima
05-12-2004, 10:28 AM
Dude a bad idle doesn't always mean its the fuel injectors, what about the O2 sensor located under the exhaost manifold. It due to be replaced now and eventually all the e30 will have to do this too.

BMW_M52_M20
05-12-2004, 03:38 PM
I am sorry guys I am not posting everything I have replaced, I have replace the intake boot and all vaccum hoses and my AFM as well as my 02 sensor.

Tell what other options it could possibly be, because I am out of options.
Jay

chromius
05-12-2004, 04:22 PM
Dude...the $170 a piece the dealer asks for fuel injectors is insane....you can get a whole set of OE injectors for $180 US! and its a DIY job too. But aside from that, the fuel pressure reg is definitly a good start, and so are the injectors....replacing mine fixed my hunting idle and rough idle too. If that dosn't fix it....the only things left that it could be are either the ECU, especially if you have motronic 1.1...or there is excessive carbon/tar buildup on your valves/intake manifold/throttle body.