PDA

View Full Version : Engine troubles...


BMWE30
04-18-2004, 04:22 AM
Hey guys...
On my way to the movies tonight, My oil light (not the low oil level light on check panel) flickered dimly for about 30 seconds randomly....on and off....almost seemed like a short....I park and leave the car for a few...cant see any oil under....I get home and park in the driveway....theres a quarter - sized drop of oil on the pavement. I move the car to the other side of the driveway, and come out a half hour later...and theres a small amount of oil. The light is not on , the car checks out, and the gauges read pretty normal. The bottom half of my engine has some oil on it for like ever, could that be like corroding this sensor...I know it has something to do with the oil pump. Do I have a serious problem here? Please help! Sorry for the lengthy post :(

felixthecat
04-18-2004, 06:26 AM
its an 87 man...gremlins show up....youre lucky your just noticeing them now...e30's have always had electrical and gasket problems...just make sure the oil is up...

BimmerKris
04-18-2004, 09:33 AM
you can get a gasket expanding compound that you put in your oil and works really well. I have used it a couple times, after having to replace gaskets. But after time i don't know how it would work on an old gasket.

chromius
04-20-2004, 12:06 AM
I would check to see if the oil filter is nice and tight, and check the connections on the oil pressure sender, the wire connections are just open to the elements, and they do get dirty. I wouldn't take any chances when it comes to oil pressure.