PDA

View Full Version : Hazard/Turn lights fuse blowing


koncise
03-06-2004, 07:25 PM
I know there's a similar topic just posted, but i dont think its the exact same situation, so I'll post my issue.

Well my fuse is blowing whenever I signal to the right. Last week I changed the wiring harness for the front-right signal, but it was fine all week. However today the fuse blew. So I changed it. Now the fuse blows as soon as I signal right (or hazards).

I checked the connections, seems good still. I cant *see* anything wrong.

any ideas?

Phazer
03-07-2004, 05:38 AM
Yeah I posted the other topic of the turn indicators. If you find out what's wrong on your car please tell me cause I cannot find anything wrong and have looked all over. I am 99% sure it's some wire that got worn abit and shifted and is touching something, or the one of the wires going into the back light cluster plug is not properly in the plug. Good luck in find the problem, cause it's a real PITA.

koncise
03-09-2004, 02:29 PM
Originally posted by Phazer
Yeah I posted the other topic of the turn indicators. If you find out what's wrong on your car please tell me cause I cannot find anything wrong and have looked all over. I am 99% sure it's some wire that got worn abit and shifted and is touching something, or the one of the wires going into the back light cluster plug is not properly in the plug. Good luck in find the problem, cause it's a real PITA.

Well I took it to my mechanic and had him check it out. Turns out it was the part that hold the actual bulb. Somehow it got a short or something in it. All is fixed now. Hope you figure yours out too.