PDA

View Full Version : Bad VIbration...Solved!


BMWE30
02-22-2004, 10:25 PM
Hey guys....I posted the problem awhile ago when I introduced myself here on the forum...My car used to vibrate badly between 30-40 mph then on slowdown it would get bad. Also it would thud a few times on take off. Well my dad and me got under it today...and we found the 4 bolts that connect the driveshaft to the flex disc and differential in the back were VERY loose and nearly off....retightened them....checked diff and added a small amount of fluid, and VOILA! Feels like a brand new car! :)....That was the only major problem with it. Now I still cant figure out why my power windows dont work...haha. :confused:

crazyvadim
02-22-2004, 11:22 PM
Wow,thats pretty dangerous.

BladeRunner
02-24-2004, 12:38 AM
man if that shafts goes is light rurrrrrrrr stop. good thing you checked it. i think i'll check mine this week...

BladeRunner
02-24-2004, 12:41 AM
when i first go my car my side view mirror didn't work. took it to the shop for tune up and my former machanic fixed them for me without me asking. Man I miss him, damn bad economy. :mad: humm maybe he does work on the side...:idea: Wait do machanics do work on the side? ohh yeah i think it was my fues or one of the connectors came loose. then again could be blown motors my mom's motor went after 10 yrs.

Mitch555
02-24-2004, 12:53 AM
Originally posted by BMWE30
Hey guys....I posted the problem awhile ago when I introduced myself here on the forum...My car used to vibrate badly between 30-40 mph then on slowdown it would get bad. Also it would thud a few times on take off. Well my dad and me got under it today...and we found the 4 bolts that connect the driveshaft to the flex disc and differential in the back were VERY loose and nearly off....retightened them....checked diff and added a small amount of fluid, and VOILA! Feels like a brand new car! :)....That was the only major problem with it. Now I still cant figure out why my power windows dont work...haha. :confused:

Good thing you fixed that problem before if became too late.

Don't you just hate it when you fix something, then something else gets messed up and you don't know how it happened? :mad: It's such a pain in the ass trying to fix the new problem!!!

BMWE30
02-24-2004, 02:58 AM
Well once in a while at odd moments you will see the window switches light up...they worked when i bought the car then they stopped a week later. One time my friend opened the pass. door and they worked until he closed it. Then today i noticed them on while driving...As soon as I touched the button they went out! Damn! I dunno...Fuses and circuit breaker on dash are okay...the fuse is..the breaker SEEMS okay...Im not sure whats going on. I HATE electrical problems.

Spencer
02-24-2004, 08:50 PM
My power windows didn't work until I changed the switches. IF they work when the door is open try cleaning the pins that connect the door to the cars wires.

Spencer

BimmerKris
02-24-2004, 10:25 PM
I had a similar problem when i got mine. The flexible cupling was ready to come apart right at the drivshaft. all the rubber was almost separted off of the bolt housing. when ever it would spin it would stretch out and it was way out of round. Under a heavy torque load it would shake around, causing the center baring to literaly bounce off the underside of my car. Replaced both of them and it felt like a new ride.

BladeRunner
02-25-2004, 10:20 PM
oh yeah did you check your flex disc to see if it needed a replacement. Someone, don't remimber who, recommended us E30 owners to check this because his/her's was worn and resulted in vibrations or funky shifting.