PDA

View Full Version : power problem


snd84318i
02-20-2004, 12:42 AM
yesterday the car starting ackting funny .15 mins into my drive to work the car lost its power . pulled over ,sounded like it was choking then it ceared upand drove fine . on why way back home ,almost here it happened again .i ajusted the idle control unit screw . opened it some and in seconds it ran normal.today ran the same ,good, on the way home it didnt stop running but i couldnt get it past 3000 rpms if i pushed the gas peddle down for more power it will slow down and lose rpms . im not ure what will cause this . i read haynes and it says a few tings air filter clogged . mines a k@n just put in 2 mnths ago . gas fitler not yet change vacume leak ,dont know were to check for that, afm looks stock . any help guys thanks

dansciol
02-20-2004, 01:29 AM
I would start with a fuel pressure check, has the filter ever been replaced?
How many miles?

BimmerKris
02-20-2004, 01:42 AM
Every so often mine will idle like shit for no apperent reason. I disconnect the battery for a couple minutes and let the comp reset itself. then it runs fine. but what your talking about sounds like bad gas to me. That happens every so often too.

snd84318i
02-20-2004, 03:02 AM
the filter im not sure car was parked for awhile though . i was thinking gas too , i try to go to the same station (hess) ive put in redline injection cleaner for to gas fulls but not on last one ive always put in 87 but in last to tanks ive put in 89 . miles it only has 123000 but not sure howit was treated . as for as i know im the 3rd owner last one says any parts and work was done by dealer . before this car ran fine pulled hard and fast .

felixthecat
02-20-2004, 03:11 AM
sounds like a fuel pump going.........

BladeRunner
02-21-2004, 01:20 AM
damn hess, :confused: that's still around. Didn't know that my car had a similar problem but only when the engine was cold. I would say it's age and milage on motor, also at that time my fuel pump was going. How much gas was in your tank? Was it less 1/2 tank full? Were you going up hill and/or around a curve or taking a turn. If you answered yes to atleast one of these questions then I'd say its your fuel pump. I told my parents that's what it was when I first got my car. They never believed me :rolles eyes: until they finaly went. :)

BladeRunner
02-21-2004, 01:21 AM
Can the MAF or AFM cause this to occur too?