PDA

View Full Version : E36 heating problems!!!!


beamerboycsl
02-18-2004, 04:49 PM
i have a 97 328i and my heating unit is ****ed. when i try to turn the heat on sometimes it wont come on at all. then if it does go on then like 10 min later the screen will either go black but the light for the direction of the air will be on still, and i cant change any settings, or it will turn on off on off on off until it either shuts off or turns on. the radio screen also go black well the lite goes out and u can kinda make out the screen. and chooses when to come on or not but the radio sounds fine and plays fine. its just the display, the heat is the display and it wont work right. i am in need of some serious help!!!!

JDub
02-18-2004, 07:26 PM
I had both of those problems at different times. When I had the radio display problem, I asked the dealer about it and they said that the radio will work but you would have to replace the entire unit to get the lights to work. :huh?: I solved that problem by getting an aftermarket deck.

As for the heater, I just had the exact thing happen to me 2 weeks ago. Found out it was the thermostat. Is your engine temperature guage going to the middle when you drive?

A~G
02-18-2004, 08:35 PM
^^^ i was just gonna say thermostat... though changing the thermostat is just a temporary fix. problem usually re-occurs down the road. I drive a mazda.. so thatz how i solved my problem.

beamerboycsl
02-19-2004, 04:01 AM
yea but would the thermostat not let me change anyof my setting via defrost, temp, postion of the air, level of air??? its kinda like it freezes to put it the best. and when ever she freezes she stays on what ever shes at and u cant change it.

JDub
02-19-2004, 01:12 PM
My heater was shutting off and coming on by itself and it happened when I pushed buttons too. After I got it fixed, no more problems.

Desisuperman
02-19-2004, 02:53 PM
I got the same problem with the radio.. lol if u bang the dash a few times and if i'm lucky it sometimes lights up again. As fas as the heater goes, no problem with the dipslay but sometime si get this weird squealing noise after the heat's been on for a while

beamerboycsl
02-19-2004, 05:18 PM
eya i get that to and its kinda when i hit the brakes but its hard to tell if its just random. but it sounds like that fan. that only happend one night and it was like 3 weeks ago. what is that all about 2.
thanks

Desisuperman
02-19-2004, 05:48 PM
dunno man, my prob with the heate comes n goes dunno what it is either

Alwysfresh
02-20-2004, 09:41 PM
If the screen is turning on and off and the fan seems to have a mind of its own it is your heater control unit. Same thing happened on mine...it's a common problem on these things. I had my old one rebuilt recently and I'm trying to unload it if you're interested. It's very easy to install on your own. I'll give you a good price if you want it (they're $450CAD new from the dealer, I paid $220CAD for the rebuild)...let me know.

beamerboycsl
02-26-2004, 07:32 PM
ok. well i got help on how to fix it myself. i guess a sodiered part broke but for about 5 bucks i can repair it myself. but BMW NA called me and is setting up a appointment for the screen.