PDA

View Full Version : wire color code .


snd84318i
02-16-2004, 01:19 PM
i just got me a deck and im goo\ing to install it . the owner before cut up the wirs so i need to rewire my deck . what is the colors for the power,ground,speakers,power ant ect thanks . a 84 bmw 318i

SebSter
02-16-2004, 03:44 PM
http://www3.telus.net/baisley/bmw1.htm

snd84318i
02-17-2004, 04:02 AM
reading my hayes book and looking into the wires hanging out i found the main power wire and ignition wire and ant wire . colors are yellow, red and blue . is there a ground wire (thinking brown) the person before had a radio in there so wires are cut and im not sure but i dont think it had a factory amp . if so i was pulled out already . can i use the power wires and ground and run my own wires for the amp and speakers . will the alarm be a problem or is it only if you have a factory amp . the radio alarm i mean . ive read that people do have issues with this . thanks

SebSter
02-17-2004, 05:58 AM
i dont think yours had a factory amp.. theres a link on that site i gave which says "if you dont have the premium sound system click here" or something along those lines

i can try to answer one of your questions though, the brown wire is in fact the ground (at least on mine it is)... and the radio alarm shouldnt be a problem... be warned though the e30s have problems when you install an aftermarket stereo, mainly the alternator whine, its this high pitched sound that accompanies your engine rev

people give mixed reasons for this: bad ground, bad wiring, etc... just today i pulled out my deck and tried regrounding it to get rid of the noise..didnt work, im probably gonna have to take the whole thing apart and rewire it all

felixthecat
02-17-2004, 10:27 PM
you need get yourself a test light...........in regards to the noise,you need to run new speaker wire.the factory stuff is crap.

lvan
02-18-2004, 04:53 AM
To me it looks confusing to play wiht those wires. In my car theer is a stock factory deck it works like dream i am not planing to take it out .Even it has nive BMW logo on it. I dont wanna get alo those cd deck that all these rice BOYs put in their acuras or civics.

SebSter
02-18-2004, 03:26 PM
its not about rice, a new deck is actually practical, like if you wanna play mp3 cds, get better sound quality, subwoofers, etc

T.Dot_E30
02-18-2004, 03:37 PM
Originally posted by lvan
To me it looks confusing to play wiht those wires. In my car theer is a stock factory deck it works like dream i am not planing to take it out .Even it has nive BMW logo on it. I dont wanna get alo those cd deck that all these rice BOYs put in their acuras or civics.

There we go again, ppl call rice whenever they dont agree/like with anything.

Im pretty sure randy(EMPOWERD), and alot of other ppl on this board including me had an aftermarket deck, i didnt know we were rice boys.

lvan
02-18-2004, 04:33 PM
yah I see your point but I only respect when I see product , Made in Germany !Yeah trust me it is so hard to find the deck pure original maybe you can but you gonna have to pay way more then these that are available in future shop or these stores that offer audio stuff.

lvan
02-18-2004, 04:57 PM
It all depends on what are you into but I dont like putting aftermarket deck that has not good quality .It's not wrong to smack aftermarketone in your car .I just wanna be different hehe.

snd84318i
02-21-2004, 12:42 AM
if you run a ground wire from under the screw from the chair , have you tried this ?

hammoj28
02-21-2004, 07:39 PM
I just installed my head unit on my E30 today and once I'd worked out what each wire was for and bought gemale adaptors for the ISO connector it was pretty straight forward.

Power: Red
Ground: Blue
Speakers: Run your own wires or chech where origionals go.
On ISO yellow meant memory back up so You put it into the same as the power(red).

snd84318i
02-22-2004, 04:11 AM
ran my wires today to about 6 hours total .all new amps rca cables ,power wire, amp wire,speakers and the dredded grounds . now for the amp i attacked it to a screw connected to a hook up top by the little pipes . i think they are for the trunk . and for the radio i connected it to a screw pasted the shifter . and yes i can here a slite humm that goes high when gas pressed . the ? is about the humm . does it come from the radio ground , amp ground or both ? dont want to move the wrong one thanks

custom_bimmer
02-27-2004, 03:41 AM
i think MOST people on this board have aftermarket decks. if i were you i would not not install my deck like that. you can go to any car audio store and get a wire harness (like $15) and you dont have to cut any of the factory wires. and it is SOOOOO easy to install a deck with this cheep part.

SebSter
02-27-2004, 05:52 AM
wow you ran new wires and still are getting the alternator whine? i was really hoping that that would be the fix, cuz as soon as the weather gets warmer i was going to rewire all the speakers... so i guess you just saved me some work there, i really need to figure out what the problem is, that whine is starting to drive me crazy

i tried regrounding from the deck ground out, that didnt work, its funny i tried grounding it to quite a few places including the screw under the chair, no luck.. so i guess thats not the only thing that needs to be regrounded


and custom_bimmer, on e30's its not as easy as other cars, because most of them come with a factory amp in the trunk, which means you need to cut wires and bypass it to install a new deck

snd84318i
03-02-2004, 12:53 AM
the person before me who had this cut the wires and connected it to his radio . i went to best but for my radio FREE install . but they said it would cost 65 dollars to install it because they had to rewire everything . no harness for this car . but all i ha to do was read and attach 4 wires . but the ground is what is puzzling me . were can you get the best grounf for the e30 or whats that sound blocking thing called and where do you connect it thanks

audiophile
03-02-2004, 12:56 AM
common ground is going to kick your ass.

you need to rewire your speakers.

snd84318i
03-03-2004, 01:03 AM
i did i ran two new sets of wires to the amp from the front set and ran a new ground wire from the radio . all other wires came from the amp wiring kit al new all ran