PDA

View Full Version : E39 540 "TRANS. FAILSAFE PROG." warning


Quack
02-07-2004, 12:23 AM
it showed up in my cluster display, does anyone know what this means? is it like in limp mode or something?
I don't know what cause it, twice in the past 2 weeks this happened:confused:

Quack
02-07-2004, 02:36 AM
*bump*.............. little help

Quack
02-07-2004, 03:58 AM
nobody eh, well I guess I have to go to the dealer & ask them

Mikester
02-08-2004, 07:02 AM
the dealer is gonna break something if nothing is wrong lol
just go to any good mechanic and he'll check it for free

Miguel
02-08-2004, 05:20 PM
Hey bud, sorry I cant help you out.. but these guys can:
http://bimmer.roadfly.org/bmw/forums/e39/

Quack
02-09-2004, 11:30 PM
thanks for the info Miguel

///Greco540
02-12-2004, 08:24 PM
It usually means that there was a problem detected and the computer switched to what's considered "limp mode" that will provide you with enough power to limp to a dealer to see what the problem is. Usually a bad sensor will trigger that fault. Take it in and have it checked out.

Quack
02-12-2004, 11:23 PM
it hasn't happened lately, I still don't know what's wrong, but I'm bringing it to the dealer soon, I wanted a more specific answer, but thanks anyways

ZiMMie
02-13-2004, 12:27 AM
U SHOULD CHK THAT ON BMW TIS.

SORRY ABOUT THE CAP
BROKEN KEYBOARD.

///Greco540
02-17-2004, 05:03 PM
Quack check for this..

1) under the car, along the side of the transmission, is the wiring with several large connectors. Check that those are in good shape and that the connectors are actually "fully connected".

2) with the ignition on (not necessary to start) move the selector lever though all the gears and see if the readout in the instrument cluster showed each gear correctly as it is selected on the shifter. If not then I would suspect a fault in the position switch on the side of the transmission, or again in the wiring from it to the transmission computer.

Good luck..

Quack
02-17-2004, 05:33 PM
thanks for the help Greco, I'm going to work on my car saturday, the damn oil seperator is also clogged up causing the car to burn oil, too many little problems all at once