PDA

View Full Version : E30 ground sucks!


Jon@Bimmersport
12-31-2003, 09:33 PM
my speakers are messed, i get static from 1 speaker..wat could it be? BMW BMXER said it might be the ground...how can i check if its good or not? Any other ideas?

the static comes each time bass comes in..and its only from 1 speaker.

Jase
12-31-2003, 09:38 PM
could be a bad voice coil. press on the speaker see if it makes a crunching sound.

Jon@Bimmersport
12-31-2003, 09:39 PM
where do i press it? i got pioneer 6x9's and theres a shiney part on top...and the blue part in the bottom..?!

BMW BMXer
12-31-2003, 09:51 PM
Press on the cone. E30s are common ground also. But Im pretty sure your car has been rewired.

Your Rear speakers are running of the amp so check the ground on the amp. You mentioned you had alternator whine fix your ground.

Also doe you still have the stock fader?

Lennon
12-31-2003, 09:55 PM
6x9's? How'd ya get those in there? Did ya cut a hole for them?

bmwm5lover
12-31-2003, 10:33 PM
i got 6X9 too, and that annoying alternator whine pisses the hell off me!!! Jon, lkets go find a shop, and see if they'll fix it on our cars for cheaper!

Jase
12-31-2003, 10:37 PM
If you have a whine in your sound system and can't find the poor ground then buy a line conditioner/ driver for your amp and a noise supperssor for your deck
Jase

bmwm5lover
12-31-2003, 10:40 PM
i dont have a amp.

Jon@Bimmersport
12-31-2003, 11:10 PM
terry, u got the stock ones...u got premium sound from iS

Lennon, i cut a whole in the back to fit the speakers.

Dave, i never had the fader?

BMW BMXer
12-31-2003, 11:54 PM
Ok. Cuz my faders all dirty so if its set the wrong way I get static. Im doing a rewire come summer.

Jon@Bimmersport
01-01-2004, 12:05 AM
wanna rewire mine too ?

windsor318is
01-01-2004, 12:08 AM
6x9's????????? lil bastard!!! LOL

T.Dot_E30
01-01-2004, 12:34 AM
I get a little whine too......it comes and goes.

I moved the ground around several times.....now its direct to the battery. I also moved the rca's from left side to right side....hmmm what else.

damn whine is still there...i give up till summer, ill rewire the speakers

Lil'Smoothie
01-01-2004, 09:20 PM
I've got 5 1/4's all around and have pretty loud alternator whine
I rippeed the stock amp out, they are running of a 4 channel Kenwood now
I dunno where the whine is coming frfom tho
what should I do?

SebSter
02-02-2004, 07:02 AM
im getting it too, and i just got everything installed a couple of days ago -shoulda read this before... ah well when the weather gets warmer ill just do the rewireing myself prolly

BMW_M52_M20
02-02-2004, 02:03 PM
Face it guys, how old are these cars? If you want decent sound, rewire the speakers! I don't know how you guys are finding poor grounds, the battery is in the trunk/or you could ground it on the body in the battery bay.

I've got a system in mine and rewired everything myself and it made quite a difference with new wiring, the old wiring was 17 years old, and it cleaned the speaker quality up alot, and thats without amplifying the speakers.
Jay

BMW BMXer
02-02-2004, 02:53 PM
I was reading the instructions for installing my deck and its bad for the deck to have it wired to the e30 common ground setup.

So basically which ever way you slice it you have to rewire.

SebSter
02-02-2004, 07:19 PM
rewire what exactly? someone said to run the power/ground wires on the drivers side and the other wires on the passanger side? and that would take care of the interference?

BMW BMXer
02-02-2004, 07:26 PM
No. Rewire all your speakers. Unless you already did that. In a stock e30 setup none of the neg(-) wires go back to the deck they all just ground out. This is horrible and does not work with most new decks.

SebSter
02-02-2004, 08:33 PM
The deck works fine though, the sound and everything is perfect.. all I want is to get rid of the whine

T.Dot_E30
02-02-2004, 09:27 PM
Originally posted by BMW BMXer
In a stock e30 setup none of the neg(-) wires go back to the deck they all just ground out. This is horrible and does not work with most new decks.

Im not sure about the the reg stereo, but in the premium stereo, Both (+) and (-) run from the speakers to the back(trunk) where the stock amp is.

But from the stock amp to the stock deck there is a common ground.

Jammasterj
02-02-2004, 11:43 PM
Wait, are you guys saying that the whine is from poor grounding??
If i were to move the grounds around then it would get rid of it?

BMW_M52_M20
02-03-2004, 01:23 AM
It is poor grounding (make sure you have the right gauge wire) or interference with other wires......

ROBM3
02-03-2004, 03:17 AM
BMW's are notorious for alternator whine...

Plain + simple.

- Make sure You guys re-route the power cables and the RCA's away from the battery cables/alternator cables.

- Get quality RCA cables.

- Make sure you have a good ground.

BMW BMXer
02-03-2004, 04:23 AM
Originally posted by ROBM3


- Make sure You guys re-route the power cables away from the battery cables/alternator cables.


:confused: :huh?:

ROBM3
02-03-2004, 04:48 AM
Originally posted by BMW BMXer
:confused: :huh?:

If your battery is in the trunk, the cables run along the doors, under the carpet.

If your battery is in the engine bay, there's no problem.

BMW BMXer
02-03-2004, 04:58 AM
Power wires near other power wires can cause interfereance?

I thought it was RCA wires near power wires that cause the issues.

ROBM3
02-03-2004, 05:00 AM
Originally posted by BMW BMXer
Power wires near other power wires can cause interfereance?

I thought it was RCA wires near power wires that cause the issues.

RCA's as well as power wires. *th-up*

Mystikal
02-03-2004, 05:17 AM
You get what you pay for, I'll always stand by that.

Jay - whose system sounds perfect and always has.

SebSter
02-03-2004, 06:03 AM
but i paid a lot :( lol

if you want a job done right, do it yourself.. thats what i stand by, so im gonna read up on it and first sign of good weather im gonna do the rewiring myself

BMW BMXer
02-03-2004, 03:59 PM
I can see how rca wires would get interferance since the carry audio signals but power wires are just power.

O well. My batt's in the trunk my power wire is all in the trunk on the other side of my rcas which are ran down the center.

My system sounds fine. I just have to wire out the factory fader for it to be 100%

bmwm5lover
02-04-2004, 01:07 AM
Originally posted by SebSter
but i paid a lot :( lol

if you want a job done right, do it yourself.. thats what i stand by, so im gonna read up on it and first sign of good weather im gonna do the rewiring myself
and if you succeed, you've got a case of beer, or w/e it is that you drink with ur name on it, so that u can do mine, how does that sound :)

SebSter
02-04-2004, 01:16 AM
lol if i succeed ill help u do it for free.. we'll share a case of beer if you want *th-up*

oh yeah that reminds me, we gotta get slowered a case of beer and go get our A/C's taken out when it gets nicer outside

bmwm5lover
02-04-2004, 01:34 AM
Originally posted by SebSter
lol if i succeed ill help u do it for free.. we'll share a case of beer if you want *th-up*

oh yeah that reminds me, we gotta get slowered a case of beer and go get our A/C's taken out when it gets nicer outside
sounds like a plan..

Jammasterj
02-05-2004, 07:43 AM
yeah it must be the wiring...

Jay- the jeep sounds great
but juliens lexus has that terrible noise and i notice it in chris's car too
i think gram ran those wires along the battery cables or something, or maybe the ground is bad

i think that noise is the speakers picking up the electrical field the alternator creates when in generates electricity...
either way the whine is really annoying!