View Full Version : Rough Idle on 318 HELP!!!!

08-23-2003, 05:05 AM
Hey guys, I get a rough idle while breaking and comming to a full stop. Now this happens when I am doing some heavy breaking, also normal and I just stop, i notice the engine shakes and the RPMs go from around 850 down to 400 then to 1200 then back to 850approx. Now if i brake heavy and once a very low speed release the brakes and let her go a little shes fine. But if i don't do that I get this shaking. ANYONE know what this could be, someone said it was the timing belt.....any merit in this???

08-23-2003, 05:22 AM
ya i have this problem as well, with me though it only happens when i'm moving coming to a stop, but when i'm at a complete stop its normal, but its bouncy when i'm approaching the stop!

08-23-2003, 05:29 AM
any ideas on fix???

08-23-2003, 05:31 AM
not too sure!
someone once told ME O2 SENSOR, but i doubt thats it!

08-23-2003, 09:03 AM
BMWF1 you don't have a timing belt.. it's chain driven so that's not likely the problem.

It might be a vacume leak or a lack of vacume when you press the breaks hard. you could also check the sensors (air flow meter, TPS, crank sensor and fuel filter) But before you spend money on that stuff, Make sure you have no vacume leaks. you could also take throttle body, air flow meter and vacume sensor valve and clean it inside with some carb cleaner. The vacume sensor is locted between the firewall and intake manifold.. or could be between the engine and the air box via a medium size hose. (looks like a pump)

I had the same problem with my engine (almost the same as yours) and after i rebuilt it and replaced a lot of sensors and hoses it went away.. so i know the problem is fixable.

good luck

08-27-2003, 09:16 PM
thanks showered, I think it may be the intake, because i replaced it with one of those "ebay ones" and now that I come to think of it, it was fine before I put it in. That piece of sh i t is being takin out right away.

08-27-2003, 09:18 PM
intakes are a load of BS, unless you do one up like mkgino did

Gino Intake (http://www.maxbimmer.com/forums/showthread.php?s=&threadid=5548&highlight=intake)

08-28-2003, 05:01 PM
I took out the intake, and its still rough on stops....ANYTHING YOU CAN SUGGUEST????????

08-28-2003, 11:40 PM
Originally posted by BMWF1
I took out the intake, and its still rough on stops....ANYTHING YOU CAN SUGGUEST????????

Did you clean up the ICV and change your spark plugs? maybe it's time for a "motor vac" or if you don't wanna spend the money run some injector cleaner, then change the oil.

i'm shooting in the air.. need more info, what have you done so far?

08-29-2003, 03:15 AM
spark plugs were changed about 7K ago to NGK's, oil was changed about 1K ago. put the original air intake system in, cleaned filter, etc. I'm a novice mechanic so I am not to sure what you mean by ICV

08-29-2003, 04:43 AM
icv = idle control valve. it's the one i was talking about in my first post.

08-29-2003, 08:06 PM
could this be why my bros 325is shakes like crazy at a light?

08-29-2003, 08:25 PM
is that the vavle type looking thing at the right side of the engine that you can kind of twist to make it go longer or shorter? Now That i know what it is, how do i go about adjusting it to make it Stable....E46 lover, i would bet it is, because mine does it and it drives me up the wall...someone told me i need to get the revs adjusted..is this what i need to do showered? I do really appreciate all your help so far.

08-29-2003, 08:26 PM
If we get this fixed i'll drive up to T.O with a case*drink*