PDA

View Full Version : shit my engine mount broke at the track


mpower1226
08-13-2003, 08:17 AM
well, here it goes, last lapping event, my engine mount broke while lapping. I knew something was wrong when I heard something broke. So I pull my car into the pit and open the hood, trying to find whats wrong. I couldnt find anything. I continued lapping untill I found somthing was seriously wrong. at the coner, I feel something is touching and making noise while I turn hard. and car was over heating, needle on red zone.

so...I drove home after cooled it down. temperture didnt go up so there I went. next morning I went to the shop, only to find the engine mount completly broken, and whole engine shifted to left side, the fan blade was touching the cover and that was why the car was overheating due to the melfunction of fan blade. I replaced the broken mount with new ones and works fine now.

hew...what a day.
just wanted to share with everyone else. ppl, check your engine mount.

KennyTheGreat
08-13-2003, 08:23 AM
damn bro...

haha


thought u were get an engine swap or something lol j/p



how much did it cost to fix???


Ken

Autotechnica
08-13-2003, 03:18 PM
Dave,

I replaced all 3 of mine recently. Do you know of any engine mount upgrades you can get? The mounts seem quite fragile. Charlie noticed mine were broken when I revved my engine and the engine was very rough. I forget how much I paid for mine, but it was a couple hundred.

Bry

mpower1226
08-13-2003, 04:07 PM
bry, as far as I know, there are some aftermaarket parts and opem parts from dealer, and oem replacement parts from some company in germany. I got oem replacement parts. it was 20bucks cheaper each. so I saved about 40 plus tax.



\kenny-well, parts werent that expensive about 80 each. and labour was free of charge. My mechanic just replaced them for free. So It wasnt bad. SC is comming soon. but now so soon. gotta pay for my tution fee first.