PDA

View Full Version : I got the shakes


burnhard22
07-15-2003, 10:57 PM
Guys, I need help!
I got a serious vibration from 80-120kms.
I just put in M3 Eurospec front control arm bushings, and had 2 rims straighten (from potholes.)
And it still vibrates..Would an alignment help or is it a particular part(s).
Give me some feedback asap..I wanna go to Cayuga b4 Autonation.
Later & Thanks
Burnhard22
*wave* *smoke*

Jon@Bimmersport
07-15-2003, 11:04 PM
cayuga? mind if i come? i swear we wont end up at the border again

lol

check for bent rims man..it could be it...i got everything checked on my bros car..and it was bent rims...so i said **** it, wait for new rims

moregothanshow
07-15-2003, 11:12 PM
i am guessing if u just did the control bushings u need an alignment....

jeremy
07-15-2003, 11:19 PM
how are your tires ?

burnhard22
07-15-2003, 11:30 PM
Yeah you can come..Fri night. The Fri day b4 Autonation.
We should see if there's a test & tune or FAst & Furious.
Jon find out and I'll drive. Get some guys from Max too.

OK..Rims are all straight...I am getting alignment on Wed and will get them to check the tires and let you know.
Thanks
*smoke*
let's go to Cayuga on Fri?

Jon@Bimmersport
07-15-2003, 11:58 PM
im down, lets go to st thomas though..its not a shithole like cayuga! ill ask rolled out to come again so he can smoke another porsche 991 C4 (993 model)

:D so can moerom

nseverin
07-16-2003, 02:13 PM
I had the shakes and had to get hub rings to fit my ace wheels
now the car drives like a dream

Slowered318
07-16-2003, 02:27 PM
Is the vibration in the steering wheel or the body of the car?

I had the shakes.. and it was the drive shaft

burnhard22
07-16-2003, 02:37 PM
The shop I bring my car to has mentioned the alignment wouldn't do too much with the vibration. They said, since there was no vibration when my 14" rims were on (while my (2) current) rims were sent out to be straightened, that it's a rim problem.?
And yes, I have the cenforical rings for the hub and yes they are the right size. I would like to agree with but that means I gotta sell my rims & tires and find another set that won't vibrate?
How can I be assured that a) it is a rim issue and b) how can I make sure it won't happen with new rims?
I don't want to spend much $ then i already have to still have this vibration.
What would you do?
*smoke*

djcontra
07-16-2003, 03:12 PM
Switch back to your 14's and see how it drives. If it's smooth, then it's probably the rims.

Rolled_Out
07-16-2003, 03:20 PM
i'll be in montreal john sorry.. can't make it i wish i could though..

Miguel
07-16-2003, 03:32 PM
Originally posted by Slowered318
Is the vibration in the steering wheel or the body of the car?

I had the shakes.. and it was the drive shaft

That's exactly what I was going to say.

I'm not to sure about E30's but on E28s, E32s, and E34s vibration between 80 & 100 kms/hr usually means that your thrust arms/upper control arms and/or bushings are shot.

I doubt it's the rims though unless the offset is way off or they are mounted incorrectly.:confused:

Albertae30
07-17-2003, 05:08 PM
i am running 16 in FRD wheels with a 35 mm offset and mine do that same vibrate like a mother from 80-100 i still can't figure it out??

djlehal
07-23-2003, 07:44 PM
I have the same problem with mine. It shakes at 100 - 120 km/h
my left mirror and rear view mirror vibrate. I am running 17's with a 30mm spacer and the rims are only a couple of weeks old.

burnhard22
07-23-2003, 11:49 PM
I found out the the hub rings that go with rims are too small in the inner of rim. It's fit around the hub of car ok but not small enough on inner diam. ALT is sending me 4 "correct" alum. hub rings on Mon or Tues it should be over then.
FYI..I already changed both f cont/arm bushings to //M eurospec and the rims & tires are fine.
You guys w/similar problems try that. Wheel balancing is good too..lol.
burnhard22
p.s thanks for all the help guys see u Sat*smoke*