PDA

View Full Version : overheating?


ptsbmw
06-25-2003, 02:27 AM
i have a 95 m3 and when i drive my car over 50 mph the car will start to overheat but when i drop my speed the car will drop quickly back down to the 1/2 mark (normal) if i sit in traffic the car will not overheat only when im on the highway or driving fast dont know whether or not if its a sensor or waterpump? also to my understanding if your car overheats or goes in the red it will stay like that for a while tilll the car cools down but it drops quickly once i start to slow down to pullover am i wrong or what i dont know whats up any advice will help also i changed the thermostat the other day figuring that was the problem but obviously not ... thanks in advance again

KIRASIR
06-25-2003, 02:50 AM
Make sure you bleed the coolant system properly. The problem might have been your thermostat initially but now you have air in the system.

It is also possible that your Head gasket is blown or block is cracked but it is highly unlikely.

I am willing to bet that you it's the air.

SL


Originally posted by ptsbmw
i have a 95 m3 and when i drive my car over 50 mph the car will start to overheat but when i drop my speed the car will drop quickly back down to the 1/2 mark (normal) if i sit in traffic the car will not overheat only when im on the highway or driving fast dont know whether or not if its a sensor or waterpump? also to my understanding if your car overheats or goes in the red it will stay like that for a while tilll the car cools down but it drops quickly once i start to slow down to pullover am i wrong or what i dont know whats up any advice will help also i changed the thermostat the other day figuring that was the problem but obviously not ... thanks in advance again

ptsbmw
06-25-2003, 05:40 AM
how do you properly bleed your coolant system?

Furious
06-25-2003, 03:14 PM
is there any greyish discolouring anywhere in the engine? check for any cracks in the waterpump, it may be working properly but at higher pressure it could be loosing coolent (long shot guess)

Marven
06-25-2003, 04:47 PM
Originally posted by ptsbmw
i have a 95 m3 and when i drive my car over 50 mph the car will start to overheat but when i drop my speed the car will drop quickly back down to the 1/2 mark (normal) if i sit in traffic the car will not overheat only when im on the highway or driving fast dont know whether or not if its a sensor or waterpump? also to my understanding if your car overheats or goes in the red it will stay like that for a while tilll the car cools down but it drops quickly once i start to slow down to pullover am i wrong or what i dont know whats up any advice will help also i changed the thermostat the other day figuring that was the problem but obviously not ... thanks in advance again

I am having the same problem...I just replaced the thermostat and the fan clutch...I am bleeding the system right now...you basically have to let the car run to medium temp shut it off and loosen the bleed screw, do it over and over...until you hear no air...I am going to go for a drive to build up pressure and do it again..apparently this is very common...I let you know the results...don't let it overheat too much...you will warp the head from the heat..also one little tid bit I found for those who did not know USE BMW COOLANT! I recently replaced a leaky rad and put in crappy tire collant...:mad:

E.