PDA

View Full Version : Brake light


Razaan
06-16-2003, 12:22 PM
Hey Guys,

I need some help. My drivers side brake light does not work. I have changed the bulb and it makes no difference. I have another set of tail lights and I have tried those as well. I put a voltmeter to the harness and nothing comes through when I press the brake. All the other lights (reverse, indicator and tail light work). Where should I begin? I have read about a Brake Circuit fix another page, can this be the case? Any help is appreciated.

Thanks

Razaan
1996 BMW 318is

Razkal
06-16-2003, 12:40 PM
I am having this same issue as well so if anyone knows why, please let us know....

:)

-=[[f|L@pJ@cK=]
06-16-2003, 01:08 PM
try checking the wires and see if they have been "pinched" causing them to short out.

I had this problem and it was simply that, and all you have to do
to fix it is get some electrical tape and go over the wires that were "pinched".

in my case the wires which these were happening to were in this
plastic piece which i circled in the picture below. All you do is
pull down the plastic piece and the wires will be there.

I'd try doing this first yourself before you take it anywhere and
have to spend money...btw it should work...i had the exact same
problem and this fixed it.

it turned out that everytime i shut the trunk, this plastic casing
holding the wires would get squished, and then eventually
happened so much that the wires started to get cut and short
each other out..

Razkal
06-16-2003, 01:11 PM
Thanks for the tip bro,

I will take a look at that tonite.

Razaan
06-16-2003, 02:16 PM
Thanks, I'll check it out.

- Razaan

Harry
06-16-2003, 03:38 PM
I had the same problem with my 320i, left side, never did figure it out.

TiemenT
06-17-2003, 10:37 AM
just buy an Z4 :D

qimis
06-17-2003, 11:25 AM
yup ... same problem with my ex 320i ... same as like other 60% 3 series back home ...

nzer
06-17-2003, 11:57 PM
fuse, relay?