PDA

View Full Version : Problems after disconnecting battery


xrayboy
05-01-2013, 07:22 PM
Hello. I disconnected the battery in my 2001 X5 when removing steering wheel to rapair the BC button. The BC button now works but when I turn the key to run the horn blasts on/off. the car will start but i have extra lights on the dash. The parking brake light stays on yellow (red if i pull the lever) the abs light stays on, and the stability control light stays on as well. The remote still works to turn the alarm on/off and unlock/lock doors.

I called a dealership and a mechanic said there could be a voltage imbalance between the car battery and alarm battery. He suggested putting a charger on battery but that didnt fix anything.

I have tried connecting battery with key in run position, no fix.

Everything worked fine before I disconnected the battery. Does anyone know what I have to do to fix this?

Dan

MountainMoto
06-05-2013, 01:10 AM
Kind of sounds like a short to ground. Recheck all your work near battery and steering wheel.

MountainMoto
06-05-2013, 01:12 AM
Also this sounds funny but try opening and closing all doors including hood and trunk then cycling your key fob locks on and off then put key in and turn to start.

MANDD
06-06-2013, 09:15 AM
Common on the X5 when the battery is disconnected and the alarm siren battery runs low on charge.

After reconnecting the battery and disarming the alarm (usually goes off when reconnecting), turn the key to position 1.

On the cluster 4.4 or MID 3.0 you will see the display counting down about 10 mins.

Sit inside until the countdown ends. Once the count down ends start the engine, it will be fine after this.

If unsuccessful the first time then try again, but unhook the battery first and wait exactly 2 minutes. Reconnect and go through the procedure again.

Mark.