PDA

View Full Version : DSC, ABS and red brake light on!


Jardine
04-26-2013, 05:34 PM
So I jacked my car up today, and painted all four calipers (didn't remove calipers or unplug anything). I put the car back on the ground, and now the ABS, DSC and red brake light are all on. I've read many other similar threads, and yes, I am getting the car scanned on sunday. I was just curious if there is a way to possibly narrow down the problem. Also:

-Odometer, L/100km, speedometer and cruise control all work fine
-I got an alignment last week, but the steering wheel is still off center. I think it is because the two front tires are different brands. Not sure if this has anything to do with the steering angle sensor or not. I've been driving it like this for a week no problem, until today.

Any help would be great guys!

jabela
04-27-2013, 02:14 AM
Maybe you painted over the ABS sensor or tone ring (toothed ring)? Or maybe you damaged or disconnected an ABS sensor?

dcramer
04-27-2013, 11:02 AM
well clearly you must have disconnected something....

Also I can't help but ask, why waste your money on an alignment with two different tires on the car ?

If the steering wheel came back off center go get your money back

Jardine
04-27-2013, 11:56 AM
well clearly you must have disconnected something....

Also I can't help but ask, why waste your money on an alignment with two different tires on the car ?

If the steering wheel came back off center go get your money back

Ya I realize something obviously disconnected. What I meant was that I didn't physically unplug anything, in order to paint the calipers. Alignment was free, my buddy did it at his shop. the tire thing was noticed after the fact. I got the alignment done the day I got the car...They're the same size, just different brand. I didn't think it'd make a huge difference, but oh well. Live n' learn..

Jardine
04-28-2013, 10:42 PM
had a p0500 - vehicle speed sensor A, code come on today. hmm

Jardine
04-29-2013, 09:47 PM
The code is just triggered by the other lights comin' on. I think I just pinched an ABS wire upon lifting the car on stands and what not. Not a big issue. thanks for the help guys!

2k328Ci
05-06-2013, 10:34 AM
My 3 lights occassionally comes on since I park it outside and the ABS sensors get dirty sometimes and gives a false error. After I drive it a little and restart the engine, the lights calm down and resets themselves - I suspect the tooth ring might be missing some teeth that might contribute to the error. So you might have a bit of overspray that crept into the sensor or ring.

Jardine
05-08-2013, 09:19 PM
ended up gettin the car scanned, and turned out the right rear abs sensor was gone. replaced it, and all lights are gone!