PDA

View Full Version : INPA - Help


madonthemike
01-11-2013, 09:23 PM
So i got a cable from ebay and finally got Inpa to work. While i can run the engine tests (by going to engine section and choosing my engine), i cant seem to get any of the functions under the E46 feature to work, they all come back saying IFH-009 - No response from control unit.

While my car does not have all the options (ECUs) - I would atleast have thought i could communicate to a few of the ECUs.

Im strating to think its more to do with the version of files that came with the Inpa setup, Im assuming that the wrong ECU file is used to talk to the ECU.

Is this something to do with the file version?

Also is there a list of E46 specific ECU and the files needed to communicate with the ECUs?

ac_2007
01-12-2013, 12:20 AM
Try updating INPA with BMW Standard Tools 2.5 if you haven't already.

As always, make sure your USB latency settings and COM port are set correctly. I was having this weird issue where only 1 side of my laptop's USB's were working completely. The other side worked, but gave errors.

madonthemike
01-12-2013, 09:07 AM
Try updating INPA with BMW Standard Tools 2.5 if you haven't already.

As always, make sure your USB latency settings and COM port are set correctly. I was having this weird issue where only 1 side of my laptop's USB's were working completely. The other side worked, but gave errors.

I think i have already, not sure which version of standard tools i installed. The instructions I have first installs the basic program and then the second part installs all the vehicle specific files. I will play around.

What version of INPA and Ediabas are you running?

Could it be that i require a different setup for a facelift E46?

ac_2007
01-12-2013, 02:43 PM
I haven't set it up in a long time.

Everything that went through my brain regarding this topic is posted here, including a tutorial on how to flash the ECU:

http://forum.e46fanatics.com/showthread.php?t=898241

Wydis
01-12-2013, 07:22 PM
I haven't set it up in a long time.

Everything that went through my brain regarding this topic is posted here, including a tutorial on how to flash the ECU:

http://forum.e46fanatics.com/showthread.php?t=898241

Same problem here,

at OP try switching between D-CAN and KCAN

im pretty convinced its the cable i purchased (this one (http://www.ebay.ca/itm/BMW-INPA-Ediabas-K-D-CAN-USB-Interface-OBD2-Diagnostic-Scanner-SSS-NCS-EXPERT-/300811788071?pt=Motors_Automotive_Tools&hash=item4609c79f27&vxp=mtr)), I have tried almost everything from the software side.

I went thru ur posts on e46fanatic and saw the link for the VAG cable (Audi/VW?), is this the cable u use for inpa? If not could you tell me which cable you use for inpa?

madonthemike
01-12-2013, 08:01 PM
Thanks,-

im pretty convinced its the cable i purchased (this one (http://www.ebay.ca/itm/BMW-INPA-Ediabas-K-D-CAN-USB-Interface-OBD2-Diagnostic-Scanner-SSS-NCS-EXPERT-/300811788071?pt=Motors_Automotive_Tools&hash=item4609c79f27&vxp=mtr)), I have tried almost everything from the software side.

I went thru ur posts on e46fanatic and saw the link for the VAG cable (Audi/VW?), is this the cable u use for inpa? If not could you tell me which cable you use for inpa?

Yeah mine looks exactly like that - i think they come from the same Chinese factory hehe. Still struggling. Check this out: http://www.bmw-driver.net/forum/showthread.php?t=30550
and scroll to post#8.

ac_2007
01-12-2013, 08:16 PM
Same problem here,

at OP try switching between D-CAN and KCAN

im pretty convinced its the cable i purchased (this one (http://www.ebay.ca/itm/BMW-INPA-Ediabas-K-D-CAN-USB-Interface-OBD2-Diagnostic-Scanner-SSS-NCS-EXPERT-/300811788071?pt=Motors_Automotive_Tools&hash=item4609c79f27&vxp=mtr)), I have tried almost everything from the software side.

I went thru ur posts on e46fanatic and saw the link for the VAG cable (Audi/VW?), is this the cable u use for inpa? If not could you tell me which cable you use for inpa?

Blue modified vagcom cable.

madonthemike
01-15-2013, 08:04 AM
It works turns out for the specific cable that i ordered I needed to solder pins 7 & 8 to use it for a pre-2006 vehicle.