View Full Version : Radio Not Working

08-16-2012, 04:12 PM
I just got straight pipes on my car and ever since my car wont start
I think the battery got shorted out while they were welding in the exhaust
You can jump start the car and it will run
But when the car is on the radio doesnt work, does that have anything to do with the battery ?
Or do you think my starter is gone?
Or what is possibly wrong with the radio

All your help is greatly appreciated

2002 325ci

08-16-2012, 05:33 PM
check your fuses first. you probably blew the radio fuse. they are completely unrelated issues. battery can't get shorted out. It was probably drained and needs charging. do a load test on the battery with a volt meter. if you're not sure. charge the battery overnight and then try starting the car.

08-16-2012, 05:39 PM
Alright I will do all that and let you know what happens

08-18-2012, 11:14 AM
I changed the battery and everything seems to be working fine now. But now my alternator has gone on vacation lol. When the cars off I get 12v but when I turn it on I get 11.8 and I believe I should be getting 14 so now I will replace my alternator.

08-18-2012, 12:06 PM
^^ dont change the entire alternator, just change your voltage regulator on the alternator.

08-18-2012, 12:23 PM
Oh okay I will look into that. Thanks a lot

08-18-2012, 04:06 PM
Just a note
My radio stopped working too.

I don't have a cd changer and the wires for it were barred and fused together with some rust creating a short.

Something to look in too

08-18-2012, 07:25 PM
on my e39 the FM doesnt work.....sometimes it works for a few minutes, then static, then silent.....AM works fine but FM is silent 99% of the time......i also took my changer out a while ago and replaced it with an amp for my front high and mids along with an ipod unit. FM worked fine for a few months after cd changer removal but then it would go silent here and there and gradually got worse until finally it stopped entirely.