PDA

View Full Version : Strange misfiring


Jabs
04-20-2012, 12:24 PM
My 323ci started misfiring last night. Ive always had the engine light on since i bought the car a few months ago but now it runs rough:
Codes:
P1188- fuel control bank 1 sensor 1
P1189- fuel control bank 2 sensor 1
P1477- leakage diagnostic pump reed switch did not open
P1421- secondary air system bank 2
P1423- secondary air system bank 1
P1250- DTC Definition is not available
P0300- random misfire
P0301- misfire cyl 1
P0302- misfire cyl 2
P0303- misfire cyl 3

I cleared the codes, the only ones that come back are the misfire codes and the p1188, p1189.
While im driving with the scanner connected, the car will stop misfiring when i clear the codes. And it will misfire again after 2-3 minutes and the codes come back. Ive tried this many times so i can stop it misfiring by erasing. Any one know what this can be? Its very strange

Eurostyle
04-20-2012, 12:59 PM
Not strange at all...And you driving for so long without fixing it does not help.
Will only get worst. Gas milage and performance are affected, not to mention you can do long term damage to sensative parts such as O2's and catalitics.

Most common source of missfire are plugs and ignition coils, mass airflow, and O2 sensors. After that it could be many things, but check the most obvious first. Trottle body is also known to fail a LOT on those cars.

Jabs
04-20-2012, 01:11 PM
Well the plugs look fine, i dot think its normal for 3 cylinders to misfire over night . Not all of them are missing at the same time though. If feels like only one. I still think it is very strange because it will stop misfiring when i clear the engine codes. Its instant

Renboy
04-20-2012, 03:03 PM
Looks like you have a vacuum leak to track down.

Jabs
04-20-2012, 04:02 PM
Yeah thats what im thinking too, i had a benz c230k for sale at my work that was misfiring until i found a vacuum hose completely disconnected from something i forget

Jabs
04-20-2012, 05:10 PM
When it misfires the revs drop very slightly and i think one of my pulleys make a loud sound like a cricket

Eurostyle
04-20-2012, 10:51 PM
Well the plugs look fine, i dot think its normal for 3 cylinders to misfire over night . Not all of them are missing at the same time though. If feels like only one. I still think it is very strange because it will stop misfiring when i clear the engine codes. Its instant

I you drove for a long time with the CEL on, its not just "overnight"...
Catalitcs and o2 sendors work on 3 cylinders each, so very nornal to have 3 missing if you have a bad o2, or cat...

Jabs
05-01-2012, 01:00 AM
Actually it was just overnight, it didnt always misfire thats what im trying to say. And i forgot to mention i probably have a bad headgasket cuz i have oil in my coolant. And i need to add water once a month. Still doesnt add up to how it stops misfiring when i clear the CEL! Lol

Eurostyle
05-01-2012, 01:20 AM
I'm not sure what part of this you dont get; if you drive your car with a CEL on, it means something is wrong, period. As time goes, things will only get worst. So one day, it WILL have other things happening, like missing, leaking, loosing power, buring oil or coolant etc. This is why you fix things early, before they become big problems. And not sure why you worry about missing when you know you need a head gasket (so new engine). Its like stressing over a cold if you got cancer! Anyways, good luck with fixing it*wave*

PS, buring coolant will mess up your spark plugs, so it will miss...

Jabs
05-01-2012, 01:37 AM
I do get what your saying. Your not getting what im saying. Im trying to figure the significance of how it stops misfiring when i clear the CEL. All the other codes are gone now so what ur trying to make me understand isnt relevant now. I dont really care about the headgasket at the moment , the car ran excellent until recently. I do appreciate the avice anyways. I just remembered the headgasket today so i wanted to see if its gettin bad now that the car will pick it up as a misfire. Happened on a civic before and a month later it lost compression in 3 cylinders lol. Im tryna delay putting an engine as long as possible.

Trekz
05-01-2012, 10:06 PM
This is actually a very common problem on 323's. I have had many customers come in with exact same issues, all it usually takes is to replace this http://kalecoauto.com/index.php?main_page=product_info&cPath=8&products_id=21 and the car runs prefect.