PDA

View Full Version : HELP! No start, no crank.


jasonbaek
04-04-2012, 12:55 PM
I just tried to start my car but it wouldn't crank or click whatsoever, nothing happened, and electronics didn't work as well(euro clock kinda works, but it's slow, and I feel no brake boost when I push the pedal) I tried to push start the car so I pushed it a bit, then I got a momentary electric power with battery warning light, then it died right away. Push start didn't work (maybe I didn't push far enough to get it going).. would there be any other issue other than battery?

Woofer
04-04-2012, 01:07 PM
Try boosting it first. Sounds like a weak battery. Perhaps you left the lights on? Sometimes the damn trunk light stays on if not properly lined up.

lost
04-04-2012, 01:46 PM
Try boosting it first. Sounds like a weak battery. Perhaps you left the lights on? Sometimes the damn trunk light stays on if not properly lined up.

I agree, sounds like a drained/dead battery.

cormier
04-04-2012, 02:53 PM
Jump it and see if it resolves

Or find a bigger hill to push-start :p

jasonbaek
04-04-2012, 06:46 PM
Yeah I took battery terminals and gave them a good clean, and re-tightened them..and everything came back to life! But now I need to find out what 4 digit radio code is...I guess I gotta go to the dealership and ask them. Thank you guys!

E30M42cab
04-09-2012, 12:48 AM
Flip through every booklet in your glove box. There's a good chance someone wrote the code down in your owners manual... and it's 5 digits.

e30tOny
04-09-2012, 06:22 AM
Flip through every booklet in your glove box. There's a good chance someone wrote the code down in your owners manual... and it's 5 digits.

.....hmmmm:rolleyes:,.....how was the vacation?