PDA

View Full Version : 335i acting funny...


BellaSignora
03-15-2012, 10:59 PM
So now that i'm out of warranty Ive come to notice a few things

Car feels sluggish at slow speeds (low rpms) and when I am de-accelerating or stopping at a light I notice my rpms jumping up and then back down.

No service lights have come on and I am overdue on a sparkplug change.

Could this be what's causing it or should I be really worried.

I had the HPFP changed last spring and haven't had any other problems other than the engine temp gauge going on me in the fall.

Any ideas? Suggestions?

Getting a little annoyed that it seems to end up in the shop every 6 months aside from regular stuff. :(

jaym3smg
03-21-2012, 12:12 PM
Could be the sparks... or the fuel pump? Take it to a shop and get the codes checked. There are a lot of codes that get thrown that won't show up on your dash.

-J

AMG_POWER
03-21-2012, 01:00 PM
my rpms running funny too, but nothing special, im at 23000 kms waiting if it will get worse.

shugalou
03-21-2012, 01:49 PM
Maf?

Jon@Bimmersport
03-21-2012, 02:26 PM
Vanos solenoids are the usual culprits for the slightly bouncy tach needle at idle, like the needle has too many grande starbucks. I'll recommend you to immediately change your plugs, and definitely look into doing your ignition coils. A shop that can check smooth running values is what you need (we can read them and diagnose your issue if you like.). You will get a code once an item or system has failed, may be starting out. JaySMG is right as well, there is static codes that get stuck in the memory causing the light to come on meaning they are currently needing to get taken care of and there are faults that come up and if it happens at a low frequency once in a blue moon the light may not stay on or even emit. That is why having a code reader can only do so much, if there's no codes then you go into smooth running values.

As per factory replacement, and oil change must be done with the solenoids. Hope this helps you N5x guys out.