PDA

View Full Version : No interior lights


Pediatrick
02-01-2012, 12:44 PM
I just got into my first e30. I have fixed many issues already but I don't know where to start with the interior lights. Anybody have experience troubleshooting these?


---
I am here: http://maps.google.com/maps?ll=50.969381,-113.959429

egye30
02-01-2012, 12:59 PM
care to elaborate? no light comes on at all? sounds like you may have a blown fuse or something, have you checked your fuses?

Bullet Ride
02-01-2012, 01:06 PM
Check the switch that's on the actual dome light to start. There's 3 positions, off, always on, and on when doors are open. Check both lights. If neither work, check the bulbs. If bulbs are good then check fuses. If fuses are good then check the switch on the dome light . 12v should be coming to one of the wires (for always on option).

Pediatrick
02-01-2012, 01:12 PM
No light comes on at all. I tested for power and no power. Which fuse should I look for. Thank you for your prompt responses

karmatose
02-01-2012, 01:23 PM
Fuse #27 (30A). Also check 6(7.5A), 19(7.5A) and 21(7.5A).

Pediatrick
02-01-2012, 01:31 PM
You got it. I'll post back after lunch

Pediatrick
02-01-2012, 03:19 PM
All fuses good still no power to lights


---
I am here: http://maps.google.com/maps?ll=50.969203,-113.959629

voluted
02-01-2012, 03:29 PM
All that's left is to check the wiring then. I had a split wire for my passenger dome light near the bottom of the B pillar which seemed like a weird spot for that wire to fatigue.

Carib
02-01-2012, 03:30 PM
Could be the bulbs are burnt out. The lights on my instrument cluster and HVAC panel were all burnt out. Replaced all of them and everything was okay. This was more than a year ago and the bulbs are still going. I guess the previous owner(s) didn't bother to replace any of them.

Bullet Ride
02-01-2012, 03:33 PM
This should help

Pediatrick
02-01-2012, 04:17 PM
I'll have a look at the wiring tonight. Thanks for all your help

Pediatrick
02-01-2012, 05:34 PM
http://img.tapatalk.com/4ac6968a-afac-f44c.jpgcould this wire be there source of my problem? Found it on the a pillar door wiring.


---
I am here: http://maps.google.com/maps?ll=50.969346,-113.960373

Pediatrick
02-02-2012, 04:04 PM
Anybody? Been looking through the Internet but still have not found any solutions. I will be working on it tonight but don't know where to start.

E30M42cab
02-02-2012, 04:36 PM
Just dome? Just console/cluster?

If you're talking about the gauge and console lights, it could be the headlight switch. There is a dimmer on it (turn headlight knob side to side), and if the dimmer quits, so do all the interior lights that run off that dimmer (dome lights are usually not affected) will not turn on at all. Does your radio work? If you think you want to try different headlight switches, there are at least three different designs that BMW used over the years. Remove yours and take it with you when hunting down a replacement.

If you're talking about the dome lights, the switch on the door jamb is usually the culprit... shitty rusted ground or sticky switch.

Pediatrick
02-02-2012, 04:49 PM
Thanks for the reply. I was referring to the dome lights. I'll pull it off and check it out ASAP. Do you think that broken wire has anything to do with it?

Hurricane240
02-25-2012, 10:15 AM
Your e30 has a dome light?! WTF!?! I want a dome light!

91 325i.. no dome light..

North
02-25-2012, 12:06 PM
If you're talking about the dome lights, the switch on the door jamb is usually the culprit... shitty rusted ground or sticky switch.

This.

Also, sometimes when hacks add an aftermarket alarm to their car, they use the door jamb switch for a door sensor.

everlast
02-25-2012, 12:16 PM
If the door switch is bad or bulb is bad you'd still have 12V at the light. The light should always have 12V, the switches provide a ground circuit. So, make sure you check the red/green wire at the light with KNOWN good ground in the car.

If you have 12V, then its a grounding problem. If you don't, then the switches, etc don't matter, its a problem on the + side of the circuit.

I don't know what the green wire is in the pic, but is that a bare wire exposed? Definitely fix if so.

criss
10-17-2014, 10:28 AM
I have the same problem all fuses are ok but the voltage doesn't go to any of interior bulbs, i have aftermarket alarm so gona check that, any other advice?