PDA

View Full Version : 87 325is- i have to pump the gas pedal to start it HELPPP PLEASE!!!!


hageali
01-10-2012, 05:19 PM
ok so, if i park my car overnight, it starts up right away in the morning with no hesitation....say i drive it for half an hour (engine warms up) and then i park it and let it sit for about 20 minutes or so and then i go to start it again....it wont start unless i pump the gas pedal, i have no idea what the problem is...



any help would be appreciated


thanks in advance

E30M42cab
01-10-2012, 05:49 PM
Cold start valve? Coolant temp sensor?

Ceeker
01-10-2012, 05:52 PM
what is the mileage? you have what is called leak down. injectors are dirty and under short driving conditions the fuel leaks into the combustion chamber causing hard start. After initial start up - short drive - then sitting. Doesn't happen to my cars often but does happen with 2 of my 3 on occasion.

run an injection cleaning system through it - Terra clean, or remove and rebuilt the injectors.

T.Dot_E30
01-10-2012, 06:02 PM
It's fuel related, check the Fuel Pressure Regulator or what was mentioned above. But it's easier to check for fuel pressure than it is to check for leaky injectors.

DIY
01-11-2012, 01:30 AM
+1 to coolent temp sensor or cold start valve...

Seems like its way to rich when its warm so it probably thinks its cold....

But I wouldn't put it past leaky injectors

Deetow
01-16-2012, 06:19 PM
I had something similar happen, and after replacing the injectors and FPR it turned out to be the Fuel Pump.

Just be sure to check things thoroughly before throwing parts at the car.