PDA

View Full Version : weird engine heating problem....no idea wtf prob is...


El Gato Liso
10-16-2011, 07:21 PM
i've pulled the cooling system of my m50 tons of times...

my problem. maybe an hour of idling...coolant gets too hot and bubbles out of the reservoir pressure hose *the skinny one that dangles*

i've changed the heater core, and the tstat. any idea why this would happen after the car has been idling for quite a bit, heater getting hot on full blast?

thanks.

Ceeker
10-16-2011, 07:28 PM
you've got air in the system. bleed it with the car on a slight hill with the nose facing up.

El Gato Liso
10-16-2011, 07:29 PM
been there done that. bled it enough times, and after an hour of idling and occasional reving....KABLOWWWWW.

Ceeker
10-16-2011, 07:43 PM
been there done that. bled it enough times, and after an hour of idling and occasional reving....KABLOWWWWW.

I beg to differ....you still either have air in the lines or you have a waterpump on it's way out. but I would bet on air... I've had this happen to me enough to know. AIR AIR AND STILL MORE AIR! it is trapped somewhere in the block most likely in the back. You should also make sure you have the heat on full when bleeding as your air could very well be sitting in the heater core.

Eurostyle
10-16-2011, 08:00 PM
Blown head gasket. It can be fine up to a week, slowly accumulating air in the cooling system, and then it gets too much. Seen it many times on Subaru's known for HG problems

noodles101
10-16-2011, 08:01 PM
headgasket problem? causing more pressure to the cooling system?

Ceeker
10-16-2011, 08:05 PM
headgasket problem? causing more pressure to the cooling system?

yes I've heard this also.

Eurostyle
10-16-2011, 08:09 PM
headgasket problem? causing more pressure to the cooling system?

Yes, can also be a crack, but those usually are much bigger and build a LOT more pressure.

noodles101
10-16-2011, 08:11 PM
yeah happend to my M52, lol... parked my car and had it idle for maybe 2 minutes and then kaboooooom , over flow tank blew up. lol

El Gato Liso
10-17-2011, 12:32 AM
^^ thats whats happening! except over a much longer period.

if its a bad HG. I would rather pull this engine and dump it, unless the head is still fine, then m52 block! although im sick and tired of working on this car lol.

we'll see...

thx for the input. its also burning coolant too. lots of white smoke on a cold start.

egye30
10-17-2011, 02:42 AM
im gonna bet my money on a bad water pump.. unless you recently had it changed..

Ceeker
10-17-2011, 09:20 AM
^^ thats whats happening! except over a much longer period.

if its a bad HG. I would rather pull this engine and dump it, unless the head is still fine, then m52 block! although im sick and tired of working on this car lol.

we'll see...

thx for the input. its also burning coolant too. lots of white smoke on a cold start.

hmm..on start up that could just be the cold start -cold motor, but if you are losing coolant -does it smell sweet? then you know you've got a blown head gasket.

blk3
10-17-2011, 11:36 AM
^^^ if its thick white smoke then its a headgasket

nachos23
10-18-2011, 11:30 AM
I'm still putting my money on the air issues..... Had the same with my car when not properly bled

El Gato Liso
10-18-2011, 01:56 PM
well compression test resulted about 210psi per cylinder, with like 2 adjacent cylinders reading about 195 or just below 200psi

i dont get this m50....dont get it at all, but its burning coolant. what a head ache...


im going to try and do the coolant again....*sigh*