PDA

View Full Version : Radio bullshit


xRAWRx
09-22-2011, 01:32 PM
when i bought the car it didnt come with a radio, so my friend gave me a deck and i decided to put it in...until i ran into this

http://i429.photobucket.com/albums/qq15/driftalwaysdodrift/IMG_0150.jpg

My wires don't match up with what people have said online so...if anyone has any ideas on how to make this work that would be rad.

thanks!

karmatose
09-22-2011, 01:43 PM
year/model?

xRAWRx
09-22-2011, 01:46 PM
87' 325i sorry

karmatose
09-22-2011, 01:49 PM
Question two. Did it have "premium sound"? AKA An amp in the trunk? Or, does it look like someone wired it out?

I'm pulling schematics now, however... if you can wait a few hours, I can take a photo of my harness at home.

lost
09-22-2011, 01:51 PM
I'm in the same boat, with no deck and a bunch of wires. Will be watching.

xRAWRx
09-22-2011, 01:59 PM
90% sure the previous owner wired it out.

And thanks anything at this point will help im tired of trial and error haha.

karmatose
09-22-2011, 02:12 PM
Alright... Here's what I can tell from the schematics.

-Ground is Brown coming from g200 (the massive ground spot behind the brake pedal.

-Constant 12v is yellow at the stereo (AKA Battery backup)

-12v ON is Violet/Grey

-Stereo lighting control is Grey/Red

-Antenna up/dn is White

Give me a few more minutes to work out the speaker +/-. The schematic is hella confusing and doesn't exactly tell you what's what.

Edit: Here's the speakers!

LF+ Is Yellow/Red. LF- is Yellow/Brown.
LR+ is Yellow/Black. LR- is Yellow/Brown
RF+ is Blue/Red. RF- is Blue/Brown.
RR+ is Blue/Black. RR is Blue/Brown.

(doing it this way will wire out the fader.)

As soon as I can figure out how to get just ONE page from the schematics as a .pdf, I'll post it so you can verify that yourself.

E30M42cab
09-22-2011, 02:13 PM
Pull your speakers out, and you'll have 8 of those wires sorted out in no time. A test light will find your power. Touch the power to the white wire (or orange if you can find it) and that should be your power antenna (mast will go up when you touch the power to it). click on ignition and that will find your main power, and your ground is left over.

karmatose
09-22-2011, 02:27 PM
http://img194.imageshack.us/img194/7276/x3e6a3e6124.jpg

There you go!

lost
09-22-2011, 03:20 PM
That's great, how about a breakdown for the heater controls!!

karmatose
09-22-2011, 03:21 PM
What year Touring is it?

lost
09-22-2011, 03:54 PM
What year Touring is it?

It's a 11/88

xRAWRx
09-23-2011, 12:36 AM
Mission Update:

I got power to the deck using

Grey/Violet - 12v
Brown/Black - Ground
Light Blue/Maroon - Ign.

...but i do not have the yellow/brown & blue/brown speaker wires.

I trial and error'd some wires but the best i get is fuzzy scratchy sound from the speakers.

nonlocal
09-23-2011, 12:00 PM
Trial and error with your speakers is a good way to destroy them. Follow e30m42cab's suggestion; you should be able to tell which speaker cables are which by pulling the speakers and seeing what's there.

MaxBell
09-23-2011, 02:48 PM
I had to do this. Basically you have to decide if you want to tear it all out and rewire or keep the existing common ground (I did).

It's not hard either way, my 87 325i took me an afternoon to wire in a deck, better amp and sub.

xRAWRx
09-24-2011, 03:47 PM
Mission Update:

Decided to re-wire the speakers and now i have music, thanks for the help friends!

karmatose
09-24-2011, 03:48 PM
Glad you sorted it out! Rewiring speakers and ditching the fader seems to be the easiest way to go.