PDA

View Full Version : Minor Oil Leak after Vanos Seals Repair, Advice Needed


Tutankhamon
09-09-2011, 12:18 PM
Hey Rocco,

Few months ago, I had the car in to get my seals repaired. Thank you for the work done as it's made a great improvement in the performance of my car. Recently however I've been noticing that there's some slight oil seepage going on at the front corner of the engine around the exhaust cam sensor. I know we had the VCG replaced as well as the vanos gasket, any idea what I can do here?

Here's a pic to help show what I'm talking about:

http://i6.photobucket.com/albums/y218/tutankhamon/2ecf7905.jpg

RMPMOTORS
09-09-2011, 02:02 PM
I have to see where the oil is coming from.

It could be from a few places.

It could be the cam sensor leaking also.

Call me to arrange a time to check it out.

Tutankhamon
09-09-2011, 02:26 PM
Sent you a pm, thx man

Hope it's nothing too major.

V8specialist
09-11-2011, 08:55 PM
You gOt your car worked on months ago? Is this a related issue?

Tutankhamon
09-13-2011, 05:47 PM
Yea like I said it's a very slow leak that I just recently noticed. I haven't even had to top up the oil. With the residue on the camshaft sensor, it might just be as simple as the seal there is failing slightly. I'll call RMP soon to schedule a quick check up and report back to update this thread.

I'm not concerned.

Tutankhamon
09-19-2011, 01:54 AM
Turns out it was a faulty valve cover gasket. With absolutely no hesitation, Rocco busted out a new gasket, opened her up and had it installed. As proof that he stands behind his work, he did it all free of charge!! What more can you ask for? I'll be keeping a close eye on it as instructed to make sure no more leaks. So far so good! *th-up*

Thanks again Rocco, car feels and looks amazing!

biginstreets
09-19-2011, 11:49 PM
and this is a prime example of why I love RMP.

JayR_84
09-26-2011, 02:45 PM
Can't say I know of any independent shops that would re-do the gasket for free 2 months after it was changed. Stands behind their work it seems.

RMPMOTORS
09-26-2011, 03:16 PM
It was actually 4 months after! LOL

Thanks guys for the kind words.