PDA

View Full Version : New to forum - need help!!


7SERIES
04-30-2011, 08:23 PM
Hi guys,

I'm new to the forum and trying to do some research on my new nightmare of a problem on my 2006 750li, however cant seem to find much. I was hoping maybe some body might know whats going on, heres what happened:


I was taking the family to a mall today, doing about 30km/h then when accelerating to 50km/h there was a huge jerk, and the check engine light came up and the car turned off.

I restarted and I quickly parked and waited. After about 20 minutes I restarted and pulled out slowly, as soon as I started driving same thing, check engine light continued to flash, then I started getting some crazy errors such dsc malfunction, transmission error, problems with P1,P2,P3, ETC on my i drive. Then a drive moderately warning.

Again I turned off, sometimes when restarting it wud shut off seconds later. Also the steering would get tight.

I was able to limp home however dont know what just happend.

Could someone please, please give me some insight???


Thank you guys in advance

Dado 540
04-30-2011, 09:42 PM
Flashing check engine light usually means missfire.

Scanning is the only solution here.

Chris05STi
04-30-2011, 09:44 PM
Check out bimmerfest, tons of e66 owners and info

7SERIES
04-30-2011, 10:21 PM
Thanks I added a thread there!

Any good BMW mechanics for my car near in Mississauga that dealt with this?

MarkD
05-01-2011, 03:40 PM
Thanks I added a thread there!

Any good BMW mechanics for my car near in Mississauga that dealt with this?

Nobody in Mississauga. Rocco at RMP is the closest to you, or there is a place in Richmond Hill that you can try.

740-iLL
05-01-2011, 07:59 PM
Welcome!

You can try Bimmersport Automotive in Mississauga located at Derry and 410

chipmunk7
05-06-2011, 11:41 AM
Hey bud, your problem is most likely related to the battery. our car is very sensitive to the voltage difference. have your battery checked.

and good luck.