PDA

View Full Version : hey all new guy with some questions


newguy
11-01-2010, 02:42 PM
hey all new guy here, lot of info on the site.
so I don't actually own a bmw yet but am talking with a guy about trading my truck for one. he has a 97 328i. it's in good shape but there's a couple things I'm not sure of making me not sure of the trade. first is the climate control. I've been reading a few posts about alot of climate control issues so it's probably common, it just stays on hot. you can turn the fan up or down but can't shut it off. the display is constantly at 16 and won't change whatsoever just constantly blowing hot. also the dash doesn't display right. it lights up but the odometer is practically unreadable but if you hit a bump or lightly tap it it will show for a minute. thinking maybe a loose connection or something. the other thing is the abs and traction control lights are on in the dash, I know it needs a wheel bearing in the front, could that cause this? it's a nice car, tan leather interior, slightly lowered, 5 spd. drives, rides and handles like a dream. I'd really like to make the trade because I've always loved these cars but just a little concerned as I don't know much about them. any info would be great. thanks

JvzwetE36325
11-02-2010, 02:52 PM
Sorry, i have a 95 325i, so i cant help you with the climate control topic. Its easy to check the cluster for loose connections, 2 screws at the top, unscrew them, pry it out, if all connections are solid then it could be a bulb (or bad internal connection), in that case you'll have to unplug the cluster, pull it out and check the bulbs in the back. As for the traction control light, he could've done the ASC delete. And are you sure its the abs light? or is it the brake pad wear sensor light?

newguy
11-02-2010, 06:02 PM
yea it was the abs light that's on. I'm thinking this weekend when I get home I have a cheap code reader I'll bring over and plug into to see if it will tell me anything. alot of people I've talked to have told me a bad bearing will cause the abs to come on and I know in alot of other car manufacturers when the abs is not working that shuts down the traction control system so I'm thinking it's probably the case. thinking this weekend I might be getting my 328 if he don't sell it first.

SickFinga
11-02-2010, 06:29 PM
Not sure why you can not change the temperature on your HVAC unit, never heard of this problem.
You might be only getting hot air because your heater valves are not working, but I'd try to fix the HVAC control unit before the valves.

You dash light sounds like a bad light bulb. Very easy fix.

ABS/ASC light is probably due to a bad speed sensor. Pretty common problem. Get a code reader, it will tell you which speed sensor needs replacing.

Vrbovsky
11-02-2010, 08:37 PM
the odometer is a common problem, its just a 1$ light bulb.

you can change the hvac control no prob for 100-150$

abs light is likely a sensor, very easy fix too. 100$ i think for the part.

you should go for it if these are the only problems

newguy
11-05-2010, 06:31 PM
just talked to him. Gonna go take another look at it tomorrow. Gonna bring my scan tool to see what it tells me. Anything special I should look for?

newguy
11-06-2010, 04:38 PM
well I did the trade today. The climate control is actually working fine through the vents but the floor and defroster are continuously blowing warm. Also must of just been a loose wire in the dash as it's working fine now.

JvzwetE36325
11-06-2010, 09:38 PM
My car is the same with heat coming out when you turn it to floor or defrost :( Great to hear the dash is working *th-up* does your a/c also come on when you turn on re-circulate? Mine does...