PDA

View Full Version : Heating Unit for a nice toasty car....


Shamis
03-31-2003, 03:01 PM
My cars heater worked fine in the very cold winter days


But for some reason since it got cold again and i started to use it it takes forever to get warm, if it even ever gets warm...:mad:


What could be causeing this?? Maybe the AC button is always on??? But the little green LED isant???

thinair
03-31-2003, 03:13 PM
Your thermostat could be stuck open, causing the engine coolant to constantly flow through the radiator (to be cooled) when it doesn't need to be.

Shamis
03-31-2003, 03:39 PM
how do "i close it" lol

WASABI
03-31-2003, 03:42 PM
Originally posted by Shamis
how do "i close it" lol

with a new one *th-up*

thinair
03-31-2003, 05:02 PM
Originally posted by WASABI
with a new one *th-up*

And while your there spend the extra money and do the fan delete mod:idea:

bmwm5lover
03-31-2003, 05:42 PM
Originally posted by thinair
And while your there spend the extra money and do the fan delete mod:idea:
what is the fan delete mod? im soo confused.....

thinair
03-31-2003, 05:47 PM
Originally posted by bmwm5lover
what is the fan delete mod? im soo confused.....

It doesn't apply to your car (proven to work on m50/2, s50/2 engines), but you change the thermostat and aux fan temp switch to new lower temp ones, run some redline water wetter, and get rid of engine fan/clutch.

I've done it and no overheating, the temp gauge just goes vertical once the engine heats up (like normal), then the aux fan turns on and the temp needle doesn't budge.

Check www.understeer.com for more info.

Shamis
03-31-2003, 05:58 PM
i think ill just leave my car the way it is......

I need new brake pads befor ei do any of this stuff lol

bmwm5lover
03-31-2003, 06:34 PM
Originally posted by thinair
It doesn't apply to your car (proven to work on m50/2, s50/2 engines), but you change the thermostat and aux fan temp switch to new lower temp ones, run some redline water wetter, and get rid of engine fan/clutch.

I've done it and no overheating, the temp gauge just goes vertical once the engine heats up (like normal), then the aux fan turns on and the temp needle doesn't budge.

Check www.understeer.com for more info.
Ok thanx...
On another note, you think its hard to install fog lights?>

WASABI
03-31-2003, 06:36 PM
Originally posted by Shamis
i think ill just leave my car the way it is......

I need new brake pads befor ei do any of this stuff lol

hey I got a set of brand new never mounted rear pads, PBR deluxe, they are dustless pads ... $30?

Shamis
03-31-2003, 06:55 PM
i need front pads :(