PDA

View Full Version : 86 bmw 325e idel all messed up need help


daveharve
12-17-2009, 10:05 PM
ive got a 1986 bmw and while i was driving it i went around a corner and i heard a clicking sound after that the rmp jumped up and it will not idel down. so if im not stepping on the gas the car is still moving and trying to drive away and when in park the rmps will over rev right up to 6000 within seconds does any body have any ideas on what this can be and what i can do to fix it
when im not stepping on the gas it easyily revs up to 1500 and will drive almost 50 kms without steppping on the gas and to stop you have to really step on the brakes hard and try to over power the car. i now let the car sit for a day and it starts up fine however when in park or neutral the car idels at 1500 but when in drive, reverse or any other gear it idels at 700 like it should does anyone have any suggestons?

daveharve
12-17-2009, 10:06 PM
please reply as soon as possible

W2WDETAILING
12-17-2009, 11:20 PM
try cleaning your throttle body sounds like its possibly jamming open if you cant figure it out there is a good shop in thorold called thorold imports they may be able to help you

daveharve
12-17-2009, 11:48 PM
i will definatly give that a try thank you

Axxe
12-18-2009, 04:28 AM
Sounds like automatic? Check to see if the throttle is operating smoothly, kick-down cable might be getting stuck.

lvan
12-18-2009, 04:39 AM
Yeah I was gonna say that. I was able to get the cable stuck. See that as well.

MANDD
12-18-2009, 06:37 PM
Brakes hard to apply?
Idle high?

Vacuum leak (major), check hose at brake booster and from booster to intake manifold.

Mark.