PDA

View Full Version : I really don't know what is problem with my 335xi coupe.


welcoomm
05-01-2009, 11:19 PM
I really don't know what is problem with my 335xi coupe.
When I press the "Engine start buttom" it has dealay time about 2~3 seconds and weired sound.

I recorded myself here is my Youtube video please check out..

http://www.youtube.com/watch?v=kg5MCwFhufY

and I went to bmw service center "steeles ave west bmw autohaus"

THEY SAID "its normal." Is this true?...please help me!!!

lvan
05-01-2009, 11:34 PM
It does not look normal to me at all.

slemmer
05-02-2009, 07:52 AM
You should go to the dealership and try out a similar car to hear how that sounds.

piotrek636
05-04-2009, 05:14 PM
what kind of gas are you using ?

every forced induction car needs higher octane gas.

drain your fuel tank and fill up on 91 octane Shell

welcoomm
05-04-2009, 06:04 PM
what kind of gas are you using ?

every forced induction car needs higher octane gas.

drain your fuel tank and fill up on 91 octane Shell

I'm always using Sunoco 94 Octance gas. Shell 91 is better?

piotrek636
05-04-2009, 06:46 PM
I'm always using Sunoco 94 Octance gas. Shell 91 is better?

94 is ok, but they add ethanol to it.

shell is the only one who has 91 octane without additives, everyone swears by it

welcoomm
05-04-2009, 08:36 PM
94 is ok, but they add ethanol to it.

shell is the only one who has 91 octane without additives, everyone swears by it

Oh I see. thank you for reply!! I'll go with Shell then haha~