PDA

View Full Version : Problem with my sunroof


eta Epsilon
05-01-2009, 06:31 PM
Hi,
I have a problem with my sunroof.
I can't close entirely on one side (driver side).
The other side close just fine.

There is a gap and I don't want water to get in there!
Do you have any idea what could be wrong???
Thanks

e30jones
05-01-2009, 06:37 PM
probably some junk stuck in the track, or the cables are out of alignment. Open the sunroof all the way, and look in the tracks. Not sure how to fix cable problems though.

Ceeker
05-01-2009, 09:28 PM
Once a cable problem you have to change it.
When they stretch or snap; the assembly has to be changed. Graphite is used to keep the cables lubricated and you can buy this pretty much anywhere. It is different from Lithium grease.
Graphite withstands extreme heat and cold weather conditions. You may also want to check for any worn or broken parts when you get the roof to tilt and not open. Tilt lets you see inside. You can also remove the sunroof liner to check. I believe 4 clips hold the front down and once this is removed you can slide the panel back but not fully opening the roof. Panel down lets you look inside to see what is going wrong. investigate in steps.
One trick a buddy of mine at bmw told me was to close the lid completely drop the sun roof motor - realign the roof so it's in place and then re install the motor to see if it works. if not then you'll have to proceed to the removal of cables.

good luck

eta Epsilon
05-02-2009, 12:12 PM
probably some junk stuck in the track, or the cables are out of alignment. Open the sunroof all the way, and look in the tracks. Not sure how to fix cable problems though.

Yes, there was a screw :eek: just beside the track that prevented the sunroof to go down entirely. I have no idea where goes that screw:confused:
I've look everywhere around the assembly but did not find anything.

It might be a screw that I placed on the roof while I was working on something else...I don't know. But anyway, the sunroof works!